Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Kokanee Ranger

Whirlpool WFC7500VW - No spin

6 posts in this topic

No finel spin on this one , seams to be trying to find a balance with 10 min left on the timer .

No fault codes. Unit drains well.

Spins up in diagnostics.

Motor checks out acording to tech sheet found on the unit.

Thinking of trying door latch and switch.

M.C.U. and main control price out at over $325 and are not returnable.

 

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Double check wire harness connector at motor.  Could try replacing door switch but tub probably wouldn't spin at all if that was the culprit.  Try unplugging the MI3 connector at CCU and check operation.  Also check same connector at MCU.

1 person likes this

Share this post


Link to post
Share on other sites

Weird stuff , today lady said she did some loads last few days . Now when she goes to start a load door lock light flashes . I have come across this before and changing the the door sensor switch has solved the problem. Changed out switch and latch .Unit today had wash light on and door light flashing  I am unable to go into diagnostics. Seems stuck mid cycle , turned off the breaker and am going back tomorrow with the ability to unstack drier.

Share this post


Link to post
Share on other sites

Had two going with no final spin. Was advised by Whirlpool Tech Line to change out the Main user interface board . His logic being if it spins up in diagnostics it's not the MCC. I have now got my hands on a Main user interface board changed out under warranty. Tenant had pushed the start button through the fascia as this unit takes f o r e v e r t o do a n y t h I n g. Ordered the board just in case and it never had a final spin issue . I will use this as a tester . Hope to have the definitive answer soon.

1 person likes this

Share this post


Link to post
Share on other sites

Did you ever find a definitive answer? I have the same thing happening with a couple of this washers. Diagnostics check out, but the units won't spin out in normal cycle. Did it end up being the Main user interface board?

Share this post


Link to post
Share on other sites

Finally got chance to use my test board .

Same problem 10 min left in the cycle and no spin. When I quoted $368.11 for user interface board ( Part number: w10192966

Part number: w10192966

) she decided to buy a new .

She called to say she had bought a larger LG washer and her husband built a shelf in the closet to set the dryer on.

She had left the whirlpool on the porch and next time I was in the area I switched out the board .

Ran a quick wash with nothing in it and it spun up and completed the cycle.

 

 

A.P.P. Sells it for $227.84 with the option to return it if it doesn’t fix your problem.

 

Might be an economical repair in the states … not so much up here.

Share this post


Link to post
Share on other sites