Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Boot Camp | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

Double oven pleb30t8ccb


  • Please log in to reply
9 replies to this topic

#1 Derik

Derik

    Sōhei

  • Chief Master Appliantologist
  • PipPipPip
  • 235 posts
  • Location: USA
  • Flavorite Brew:coors light

Posted 22 May 2013 - 11:44 AM

Upper oven no bake or broil!!! Check across each side of element and get 120vac, check across both together and no voltage!!! Can't find no burnt wires!!! Any ideas where I lost my neutral

Bottom oven works fine on broil and bake!

Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 KurtiusInterupptus

KurtiusInterupptus

    B.M.F.

  • Academy Fellow
  • PipPipPipPipPip
  • 1,820 posts
  • Flavorite Brew:Killians Red

Posted 22 May 2013 - 11:46 AM

No neutral loss...pull the upper oven relay board and see if you see a burned solder on the double line break...might be able to repair it, if so.
As every cockroach knows , thriving on poisons is the secret of success.

#3 Derik

Derik

    Sōhei

  • Chief Master Appliantologist
  • PipPipPip
  • 235 posts
  • Location: USA
  • Flavorite Brew:coors light

Posted 22 May 2013 - 11:48 AM

Which is upper oven relay brd

#4 RegUS_PatOff

RegUS_PatOff

    Sensei

  • Academy Instructor
  • PipPipPipPipPip
  • 33,588 posts
  • Location: USA
  • Flavorite Brew:Chief NTSC Black & White

Posted 22 May 2013 - 11:51 AM

Oven Elements are 220v ... they don't use Neutral

try pushing the red reset button on # 119

Have you used Self-clean lately ?  :nono:

R0303036-00002.png


.

one of my video productions: “Easter Seals: Walk With Me”

every day is Down Syndrome Awareness Day
"A Child Is Waiting" . Burt Lancaster . Judy Garland . 1962

RegUS_PatOff > www.youtube.com/watch?v=oPAY2LsKVEw

#5 KurtiusInterupptus

KurtiusInterupptus

    B.M.F.

  • Academy Fellow
  • PipPipPipPipPip
  • 1,820 posts
  • Flavorite Brew:Killians Red

Posted 22 May 2013 - 11:53 AM

Not sure..are both ovens convection?
If not, the one with the extra relay.
Or you could check both.
As every cockroach knows , thriving on poisons is the secret of success.

#6 Derik

Derik

    Sōhei

  • Chief Master Appliantologist
  • PipPipPip
  • 235 posts
  • Location: USA
  • Flavorite Brew:coors light

Posted 22 May 2013 - 11:53 AM

Had already checked reset button on thermodisc and the sensor is closed(good)! No self cleaning for us

#7 RegUS_PatOff

RegUS_PatOff

    Sensei

  • Academy Instructor
  • PipPipPipPipPip
  • 33,588 posts
  • Location: USA
  • Flavorite Brew:Chief NTSC Black & White

Posted 22 May 2013 - 11:58 AM

sounds like the DLB Relay on the Relay Board may be bad
http://www.repaircli...18022002/499739

 

Relay-Board-318022002-01109610.jpg
 
make sure neither Element is partially shorted to chassis /ground..
may have caused Relay failure.
 
While either Element should be heating,
measure the voltage across the wires exiting the top of the DLB Relay (while connected)
0v = good
240v = bad


.

one of my video productions: “Easter Seals: Walk With Me”

every day is Down Syndrome Awareness Day
"A Child Is Waiting" . Burt Lancaster . Judy Garland . 1962

RegUS_PatOff > www.youtube.com/watch?v=oPAY2LsKVEw

#8 Derik

Derik

    Sōhei

  • Chief Master Appliantologist
  • PipPipPip
  • 235 posts
  • Location: USA
  • Flavorite Brew:coors light

Posted 22 May 2013 - 12:10 PM

Thanks everyone!!! Relay brd with transformer had two seperate cold solder spots on back of control!!! Resoldered both and back in bizness!!! U guys r awsome and quick to reply!!!

#9 KurtiusInterupptus

KurtiusInterupptus

    B.M.F.

  • Academy Fellow
  • PipPipPipPipPip
  • 1,820 posts
  • Flavorite Brew:Killians Red

Posted 22 May 2013 - 12:14 PM

Nice work :-)
As every cockroach knows , thriving on poisons is the secret of success.

#10 Samurai Appliance Repair Man

Samurai Appliance Repair Man

    Shōgun

  • Fermented Grand Master
  • 28,699 posts
  • Location: USA
  • Flavorite Brew:Sapporo Original Draft Rice Lager

Posted 22 May 2013 - 04:16 PM

Jolly good show!  celebrate11.gif






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Boot Camp | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics