Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

richseattle56

KSSC36QTS02 KitchenAide SXS Control Does Not Come On

13 posts in this topic

KSSC36QTS02 KitchenAide SXS Control Does Not Come On.

 

Customer called KitchenAide when fridge started making strange noise from the condensor area. Support told him to shut the fridge off for 5 to 10 minutes and then power up. When power was turned on the control did not come on. The control tries to come on and then goes off after a few seconds.

 

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

The control tries to come on and then goes off after a few seconds.

 

 

Are you referring to the user interface display or the main control board?

Share this post


Link to post
Share on other sites

Are you referring to the user interface display or the main control board?

Yes the user interface does not come on or respond.

Share this post


Link to post
Share on other sites

Power Supply is OK. Smells like burnt electronics in the fresh food section. When you open the FF door the control is completly off. Press the power button I hear a a short buzz then the compressor starts for a few seconds and then stops. The condensor fan ran for a few seconds and then stopped. Put it in diagnostics, which it did enter, ran the FZ thermistor test, passed, ran the FF thermistor test, passed, went to evap fan test, control went blank and could not do anything with control. Any ideas?

 

Thanks

Share this post


Link to post
Share on other sites

Control board and evap fan motor. Need to pull board and send to corecentric for rebuild. NLA from whirlpool.

Share this post


Link to post
Share on other sites

Check evap fan motor and Gemini board as Brother NCA advised.  I remember this was the model I had a defrost/temp/display problem with that I couldn't pin down.  Techline advised replacing both Gemini and niagra boards but to no avail.  Had me checking power supply and ICC boards.  Problem turned out to be interface control.

Share this post


Link to post
Share on other sites

I have no idea what the problem was. I called the customer today to go and take the Gemini board out and send it to CoreCentric for repair. He said fridge is working fine. His next door neighbor came over and reset the controls and unit is working. KitchenAide Support told him that it is a temporary fix the fridge will shut down in a week or 3. I did the reset the other day and nothing. Had the tech sheet from beside the upper unit parts. Nothing. His next door neighdor came over after a KA authorized repair tech came out and told him he had to replace the whole fridge. This is a high unit fridge like Chev to Cadillac. It's all crap compared to the old days. Do any other tech's notice you do alot more repairs on appliances 5 years old and newer than stuff 10 years old?

Share this post


Link to post
Share on other sites

Corecentic? I know a place that's waaay more betterer AND they're friends of Appliantology: Fixyourboard.com. Consider giving 'em a shot next time.

Share this post


Link to post
Share on other sites

fixyourboard does not rebuild the gemini board

Share this post


Link to post
Share on other sites

Update. Had customer send board to CC. I was out of town had a fellow tech go to put board in. Board blew on power up. Sent board back to CC. Before putting board back in fellow noticed power supply board had burnt resistor. When Main board came back from CC put new PS board and rebuilt main board in, no display on dispenser. Went to RC repair help said main board?????? may be problem. Any suggestions or help.

Share this post


Link to post
Share on other sites