Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

  • Announcements

    • Samurai Appliance Repair Man

      ***READ THIS PRIOR TO STARTING A NEW TOPIC***   05/02/2016

      Topics with the complete and accurate model number in the topic title will get priority attention. You can validate your model number by entering into the form on this page: http://www.repairclinic.com/?clearLs=true For more help on using Appliantology effectively, please see this page:  
Derik

Kenmore sxs 25355674402

9 posts in this topic

Frig no cool have 120vac to evap fan motor but no spin!!! ??????? Any u appliantoligist seen this??? Take test wires to fan motor and plug into wall and fan works great???? HELP PLZ WARM BEER AND MELTED ICE!!!!

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Bad fan motor.

Share this post


Link to post
Share on other sites

Fan works fine if plug it into test wires and shove them into a wall outlet though!!!!!!

Share this post


Link to post
Share on other sites
... Frig no cool have 120vac to evap fan motor but no spin!!! ???????

... Take test wires to fan motor and plug into wall and fan works great????

all voltage measurements should be made with the devices connected,

unless otherwise directed

http://www.repairclinic.com/referral.asp?R=154&N=1614983

 

Defrost-Control-Board-5303918476-0117628

Share this post


Link to post
Share on other sites

Sorry man , I misread that...suspect a bad defrost thermostat. failing under load...power seems there ,but won't run the fan. See if the top is "popped"

Share this post


Link to post
Share on other sites

Whoops, another swing and a miss...reg is prolly right. The fan power doesn't go thur the defrost tstat on this unit. Disregard.

Share this post


Link to post
Share on other sites

...suspect a bad defrost thermostat. failing under load...

usually on Amana's

this is a Frigidaire Kenmore   :beatnik:

Share this post


Link to post
Share on other sites

Dang reg, I already sez I wuz wrong! Lol

Share this post


Link to post
Share on other sites

Only popped top is on my beer:) found adc brd on my truck and was in the middle of changing it when seen responses from REG and Kurtis!!! Thanks for help and replies!!! U guys rock and hope this helps someone somewhere.!.!.!

Share this post


Link to post
Share on other sites