Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Isn’t it time to know what you don’t know?

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
hoagie1

Amana refrig

6 posts in this topic

I have an amana model # 36791 but everyone says that's not a model # so I have to give them the Mfg. # P1152601 ww. The condenser coils keep on icing up. I am using a blow dryer on them every three or four days. I thought it was the defrost thermistor, hoping it wasn't the defrost heater, so I replaced it, to no avail. Still doing it. I can't check for voltage at the heater because I can't put it into defrost mode. I tried the light switch thing, by switching it on and off five times. But that didn't work. Is there another method? Now you are going to say it's the circuit board. I don't think it is. I have 9 volts ac to the defrost heater. But I don't know if it is in the defrost mode or not. It does cycle, but doesn't defrost. I can't find anything on the energy saving switch, and it seems th be tied in to the defrost heater.  WHAT SHOULD I DO?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

That heater would need 120 volts ac to defrost. If your getting 9 volts, the relay on the defrost  control board is probably bad. I'm not familiar with this specific model, but many can be tested by using a mechanical defrost timer.

Check all the connections, and test to see if your heater is bad(got a meter?)

You may just have to buy youself a new defrost control

Nick

Share this post


Link to post
Share on other sites

Thanks for the reply. I do have a meter. I ohmed out the heater and got like 30 ohms so I think it is good. but the nine volts I was getting is not a true reading because It is not in defrost mode. Do you know how to put it in defrost mode? It might not be a bad idea to put a mechanical timer on it, is it easy to wire up?

Share this post


Link to post
Share on other sites

[user=612]hoagie1[/user] wrote:

Do you know how to put it in defrost mode?

Open the beer compartment door and press the light switch five times within six seconds to initiate defrost.  If the board does not respond, replace the board. See this page for more information.

Share this post


Link to post
Share on other sites

smile.gif

Thank you exaulted one. I was not convinced that it was the board, but when you said after hitting  the light switch five times if it does not respond, it is the board, you convinced me. I traced the problem to a relay on the board. I jumped it out and it is defrosting. I will replace the board and immediately go to the house of woes and await my punishment. 

yikes.gif

Share this post


Link to post
Share on other sites

[user=612]hoagie1[/user] wrote:

... and immediately go to the house of woes and await my punishment. 

 

Punishment for what?  You found the problem.  Nice shootin', Hoss!  :armed:

Share this post


Link to post
Share on other sites