Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

prairiestr

Whirlpool WFC7500VW1

12 posts in this topic

Cust. complains clothes spin but only at low speed.

Anyone seen this?

Suspect door switch but I am not familiar with this model.

Any tips appreciated.

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Update;

Ran diagnostic test, F13 code appeared (door lock)

Continued through test. pump seems ok, inlet valves ok, spun at high speed,,,

Still suspecting door switch but would like some input from someone with experience with this model. 

Thanks.

Tech sheet?

Edited by prairiestr

Share this post


Link to post
Share on other sites

Still looking for some advice.

Has anyone seen this model /problem before?

Share this post


Link to post
Share on other sites

If diagnostics says door lock error,

and it will Spin in high speed in diagnostics..

Sure sounds like a bad Door Lock / Latch or Switch

Share this post


Link to post
Share on other sites

Thanks Reg,

I will order one and try it.  :kopkrab:

Share this post


Link to post
Share on other sites

have you inspected / tested the Latch / Switch / actuators ?

Share this post


Link to post
Share on other sites

Yes, I looked at the latch and switch and wiring, no visible defects.

Share this post


Link to post
Share on other sites

I had two on the go at one time .

If the control was not seeing the door switch.

The wash drum would not move and no water would come in.

 

For no high speed spin ...

Was advised by Whirlpool tech line to change out the user interface - control board. (CCU Assy.)

As these boards  W10192966 are pricey $285.00 .

Nether went ahead with the repair.

Share this post


Link to post
Share on other sites

Wall Center False Creek . 

Under construction , with 2 out of 4 towers now being occupied . 557 Units , each one has a WFC7500VW

There is a good chance I will run into this problem again.

Share this post


Link to post
Share on other sites

Update:

Cust says she "shimmed" the switch actuator with tape and it has not failed since.

Looks like latch/switch issue.

Parts on the way.

Thanks for the help. :wink:

Share this post


Link to post
Share on other sites

I have taped a nickel to the inside of the door ! To insure plunger on door switch is activated.

A " non standard repair "

 

This did not work on a unit with no finale spin.

Share this post


Link to post
Share on other sites

Kokanee,

What was the final outcome of that job? (what part failed?)

Share this post


Link to post
Share on other sites