Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn how to be your own tech line...

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
ScottsApplianceRepar

Electrolux Fridge No Start & Displays "OP / OP" after replacing touchpad and main board.

7 posts in this topic

The parts involved with this one were on back order for 3 weeks so this is a popular puppy.... some of you guys have to have run into this interface on one of Electrolux's fridges somewhere. What I really want to know is if anyone has faced this before and, if so, are there any tricks / caveats / etc. that I need to be aware of.

 

It's a bit long but I tried to write it in an entertaining style. I hope you enjoy.

 

Thanks!

 

Scott

 

**********************************

 

Electrolux M# EW26SS65GS0 Fridge

 

Original complaint: Solved

 

Secondary Complaint: PF alarm won't reset, parts of interface touchpad unresponsive.

 

Ordered interface:

     5303918582
     FRG - USER INTERFACE KIT

 

Waited 3 weeks for backorder to arrive while customer called every single day because she was going insane. The loud beeping could be heard in every room in the house, including the bedroom... at 2AM... and 3AM... and 4AM... etc...

 

Part arrives, it's a kit consisting of a new interface AND new main board. They must be replaced as a set. What was to be 2 screws and 3 minute job turns into a pain the the a** because the main board is mounted under, yes under, the fridge. I will gladly pay $500 for 5 minutes in a locked closet with the engineer who thought THAT was a good idea. But I digress...

 

So I get it done, plug it in and it goes beeep. I hit the reset and it goes quiet and all is well in Mudville.

 

Three seconds later both displays change to OP / OP and the unit refuses to start, AT ALL. :wacko:

 

Oh yea....... we is havin funs now.

 

There is a number to call on the instructions if you have any issues or suggestions. I call it. The computer asks for an authorized contractor ID number. I hit 0 for operator, it says go find my number and hangs up on me. I call back, it hangs up on me again.

 

I begin to contemplate a road trip to Electrolux land to commit acts that would result in a lengthy prison term. :samurai:

 

I get customer service on the phone and the girl tries her best. She defines OP as open thermistors, both Fridge and Freezer. Apparently the wiring has an open. I quadruple check it all, looks great, still no joy.

 

So I do the test of last resort... I put the old part back in.

 

Vrrrrrooooommmm!!!!!! She runs!

 

Beeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeep................. Beeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeep.................

 

Just kill me now... please...

 

Electrosux... lux, whatever... expressed a new set of boards since there is clearly nothing wrong with the thermistors or the wiring and the new boards have to be faulty. I picked up the new ones today and will be putting them in tomorrow. If anyone has any tips or warnings about this beast, I'd appreciate any heads up.

 

Thanks!

Edited by Vets Appliance

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

... both displays change to OP / OP

Freezer Thermistor "open" / Fridge Thermistor "open"

check J6 on Controller

Share this post


Link to post
Share on other sites

I know Reg, but the old boards don't have that fault at all. Only the new ones did.

 

If the second new set has the same issue, that's the first thing I'm going for though... after my aneurysm.

Share this post


Link to post
Share on other sites

is J6 fully / correctly inserted ?

Share this post


Link to post
Share on other sites

I'm heading out there in about an hour with a new set of boards. I had checked all connections at least five times with the last set and as soon as I put the old parts back in she fired right back up so I think the connections should have been fine.

 

However I will definitely keep J6 at the front of my mind when I walk in their door.

 

Thanks

Share this post


Link to post
Share on other sites

Hi Vet,

Would you by any chance have a update for your dilemma on the lovely Frigidaire frig.

Thanks

Share this post


Link to post
Share on other sites

could op mean open door, per chance??

Share this post


Link to post
Share on other sites