Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

GE GSS25LGMFWW Defrost Issues


  • Please log in to reply
10 replies to this topic

#1 sluggo0018

sluggo0018

    Samanera

  • Grasshoppah
  • Pip
  • 8 posts

Posted 09 September 2013 - 04:50 PM

The freezer defrost function wasn't working and the evap was freezing up, causing temps in the freezer to warm up to 20-30 degrees F.  I did some research and decided to change the defrost heater (upgrading to the two element unit) and also changed the thermostat switch.  This didn't fix it so I replaced the motherboard.  I don't usually throw replacement parts at a problem hoping it will be fixed, but this time I did.  Shame on me!So at this point, the unit has a new heater, thermostat and motherboard. 

 

Today, I happened to notice that there was no fan or compressor noise coming from the unit.  I opened the freezer to see the glow of the heater below the evaporator and heard some sizzling noises as Ice melted down and dripped onto the heater. All was fixed I thought!   But it seems as though the defrost function doesn't stay on long enough.  There is still ice on the interior panel that covers the evaporator and freezer is still running warm at 20 degrees F well after the defrost cycle.  I haven't removed the cover to look at the coils, but I think there is still ice and frost.  Evap fan seems to be running properly.

 

Is there anything that I can adjust to prolong the defrost heater to fully defrost the coils?  What determines how long the defrost cycle runs?  When free of ice and frost, the freezer cools great, reaching 0 degrees F rapidly. 

 

Is there a way to manually activate the defrost cycle?  I'm guessing that there isn't considering the electronic controls. 

 

Does this unit have a defrost timer?  My understanding was that all defrost operations are controlled by the motherboard.

 

What is my next step?  I've been struggling with this freezer and I've gotten really fast at defrosting it, but I want it to work properly.  The wife is giving me a hard time about it.  She wants a new stainless steel fridge.

 

Thanks.



Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 KurtiusInterupptus

KurtiusInterupptus

    B.M.F.

  • Appliantology Fellow
  • PipPipPipPipPip
  • 1,822 posts
  • Flavorite Brew:Killians Red

Posted 09 September 2013 - 05:18 PM

that thermostat at the top of the coil is not a traditional defrost bimetal...it is a overtemp protector in case the heater sticks on a the board...you need to replace the thermistor adjacent to that thermostat...it controls duration of defrost cycle.
As every cockroach knows , thriving on poisons is the secret of success.

#3 micabay

micabay

    Senpai

  • Sublime Master of Appliantology
  • PipPipPipPip
  • 686 posts
  • Location: USA
  • Flavorite Brew:Drifter Pale Ale

Posted 09 September 2013 - 05:41 PM

Did you fully defrost everything?

#4 Samurai Appliance Repair Man

Samurai Appliance Repair Man

    Shōgun

  • Fermented Grand Master
  • 28,816 posts
  • Location: USA
  • Flavorite Brew:Sapporo Original Draft Rice Lager

Posted 09 September 2013 - 05:42 PM

..you need to replace the thermistor adjacent to that thermostat...it controls duration of defrost cycle.

 

 

Yes, the one clipped to the evaporator: http://www.repaircli...55X10025/914093

 

 

Thermistor-WR55X10025-00855831.jpg



#5 sluggo0018

sluggo0018

    Samanera

  • Grasshoppah
  • Pip
  • 8 posts

Posted 09 September 2013 - 06:49 PM

Did you fully defrost everything?

 

Yes.

 

The freezer was fully defrosted before I installed the motherboard.

 

Looks like I have one more item to replace.

 

I will order the thermistor and give that a try.

 

Is that a simple cut and splice procedure?



#6 Level2Learning

Level2Learning

    Samanera

  • Professional Appliantologist
  • Pip
  • 15 posts
  • Location: USA
  • Flavorite Brew:Corona

Posted 09 September 2013 - 07:20 PM

Sluggo,

 

The thermistor is the most likely culprit on these refrigerators.  The board watches it during defrost and post defrost.  It ignores it during other cycles.

 

This particular thermistor is interchangeable with the rest and it is currently a WR55x10025, as long as the appliance has white wires going to it.

 

Because it operates at a temperature range of  about -25*F to 60*F up to 3 times a day, it takes a beating. Moisture is also known to 'creep' its way into the capsule.

 

When replacing, cut and splice it in AND fill the connector with a silicone, FDA food grade, (usually has a vinegar odor) sealant.

 

Good Luck.


Level 2 Learning "taking learning to the next Level"


#7 bigbuck

bigbuck

    Sōhei

  • Master Appliantologist
  • PipPipPip
  • 236 posts
  • Location: USA
  • Flavorite Brew:Red Wine

Posted 09 September 2013 - 08:18 PM

http://www.repaircli...ber=GSS25LGMFWW

G.E recommends replacing both safety thermostat and defrost heater or vice/ versa.


Edited by bigbuck, 09 September 2013 - 08:25 PM.


#8 Level2Learning

Level2Learning

    Samanera

  • Professional Appliantologist
  • Pip
  • 15 posts
  • Location: USA
  • Flavorite Brew:Corona

Posted 09 September 2013 - 08:29 PM

BigBuck... I believe he changed all of that already and has the same issue.


Level 2 Learning "taking learning to the next Level"


#9 Cactus Bob

Cactus Bob

    Senpai

  • Sublime Master of Appliantology
  • PipPipPipPip
  • 553 posts
  • Location: USA

Posted 10 September 2013 - 01:13 PM

mistake sorry , got people mixed up


Edited by Cactus Bob, 10 September 2013 - 01:19 PM.

SORRY ABOUT THE SPELLING , I FIX GREAT , I DON'T SPELL WELL

#10 sluggo0018

sluggo0018

    Samanera

  • Grasshoppah
  • Pip
  • 8 posts

Posted 10 September 2013 - 01:22 PM

did you replace the thermistor ? post #4 of this thread ?

did you or did you not , "i think i did" does not count

 

 

At this point, I have relaced the defrost heater, thermostat, and mother board.

 

I don't ever recall saying that "i think i did" replace the thermistor.

 

The thermistor has been ordered and will be the next part replaced.



#11 olyteddy

olyteddy

    Kohai

  • Sublime Master of Appliantology
  • PipPipPip
  • 300 posts
  • Location: USA
  • Flavorite Brew:Earl Grey

Posted 10 September 2013 - 10:56 PM

Pretty easy to check the thermistor from the motherboard connector. (unplug the fridge from the wall) Find the connector at J1 and disconnect it. The freezer evaporator thermistor is connected to pins 4 & 5 (blue/white and blue). Ice water is 32 degrees and the thermistor should measure 16.3K Ohms at that temperature. This thread describes the procedure: http://appliantology...ermistor-magic/






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics