Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Dumbstruck by the new computer-controlled appliances? Let the Samurai enlighten you…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
jackie

ge refrig problem

4 posts in this topic

have a ge model no. gsl25jfpabs.   nothing is cooling...evap and condenser fans running....compressor is not....is cool to touch, no noise or vibration.  is it the motherboard that is faulty?...checked start relay, does not rattle....and seems there is no voltage to compressor....is mother board most likely cause?

 

thanks in advance

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

have a ge model no. gsl25jfpabs.   nothing is cooling...evap and condenser fans running....compressor is not....is cool to touch, no noise or vibration.  is it the motherboard that is faulty?...checked start relay, does not rattle....and seems there is no voltage to compressor....is mother board most likely cause?

 

thanks in advance

also could it be one of the thermistors bad

Share this post


Link to post
Share on other sites

...evap and condenser fans running....compressor is not....

...checked start relay, does not rattle....and seems there is no voltage to compressor

also could it be one of the thermistors bad

 

If the Fans are running, the Thermistors are telling the MotherBoard the Fridge needs Cooling

http://www.repairclinic.com/referral.asp?R=154&N=1531075

Main-Control-Board-WR55X10942-01091474.j

Share this post


Link to post
Share on other sites

Jump between J8 and J11 on the blue 3 terminal plug on motherboard, if compressor runs, bad board.

Edited by richseattle56

Share this post


Link to post
Share on other sites