Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Isn’t it time to know what you don’t know?

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
prairiestr

hotpoint VBSR3011G1WW

10 posts in this topic

No motor status light is visible, lid switch ok, power at orange wire at motor.

Bad motor?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

check that model number again ?

Share this post


Link to post
Share on other sites

Sorry, that should read VBSR3100G1WW

Share this post


Link to post
Share on other sites

Uhhh,... I...   didn't.....        check that... :wacko:

I'll report back soon.                            :stupid:

Share this post


Link to post
Share on other sites

Update;

thermal fuse checks good, still no light at motor.

Share this post


Link to post
Share on other sites

Can I "assume" that the inverter board on this motor is bad?

Share this post


Link to post
Share on other sites

never assume anything it makes  an ass u me

Share this post


Link to post
Share on other sites

if u are getting the proper power and neutral at the motor then yes the inverter is bad

Share this post


Link to post
Share on other sites