Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

jss_old

Dacor Single Oven MCS130S

4 posts in this topic

Broil element not working when broil selected and does not self-clean well.  Pulled grid and pushed red button on high temp thermostat to reset but no effect.  All other functions work fine.  Anything further I can do as a DIYer? Thx.

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

... Broil element not working when broil selected

... and does not self-clean well.

1) may be a bad Broil Element OR a bad Oven Controller

2) :woot:

“My Rules”:

Rule #1) Don't ever use Self-Clean on any Oven.

Rule #2) If you're thinking about using Self-Clean, see rule #1.

Self-Clean uses nearly 1000F for 3 hours or more. burnin.gif

That can wreak havoc on Electronic Controllers and Connections.

 

http://www.repairclinic.com/referral.asp?R=154&N=1036110

Broil-Element-62723-01203277.jpg

 

http://www.repairclinic.com/referral.asp?R=154&N=1012426

Oven-Control-Board-62964-01517239.jpg

 

Share this post


Link to post
Share on other sites

Is there a way to test these to determine if both or just one have malfunctioned? Is there a diagnostic program that can be run? Thx.

Share this post


Link to post
Share on other sites

Someone would need to test the Broil Element with an OHM meter,

OR a good visual inspection may notice that it is broken.

If it's not a bad Broil Element, then most likely, the Oven Controller is bad

 

Share this post


Link to post
Share on other sites