Jump to content


Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

Imperial 60" Gas Range Model IR-6-24


  • Please log in to reply
4 replies to this topic

#1 computepulse

computepulse

    Unsui

  • Grasshoppah
  • Pip
  • 3 posts
  • Location: USA
  • Flavorite Brew:Michelobe Ultra

Posted 02 June 2014 - 09:53 AM

I have an Imperial Gas Range IR-6-24 in which the left side oven burner does not seem to be getting a strong enough flow of gas because the gas lights and just spirals around the burner.  Pilot seems fine.  I have never worked on this unit before so I am asking for someone who has experience on this model. 

 

Thanks in advance



Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 computepulse

computepulse

    Unsui

  • Grasshoppah
  • Pip
  • 3 posts
  • Location: USA
  • Flavorite Brew:Michelobe Ultra

Posted 02 June 2014 - 10:50 AM

http://www.facebook....808385692507299           



#3 computepulse

computepulse

    Unsui

  • Grasshoppah
  • Pip
  • 3 posts
  • Location: USA
  • Flavorite Brew:Michelobe Ultra

Posted 02 June 2014 - 12:04 PM

Sorry it's a IR-6-G24 Imperial commercial oven



#4 tommytech

tommytech

    Sōhei

  • Appliantologist
  • PipPipPip
  • 176 posts
  • Location: USA
  • Flavorite Brew:guiness

Posted 06 July 2014 - 08:59 AM

did you check gas pressure? gas volume? is the orifice sized correctly or correct size? does it have an air shutter,and is it adjusted correctly?



#5 computerpulse

computerpulse

    Sōhei

  • Scholar of Appliantology
  • PipPipPip
  • 110 posts

Posted 06 July 2014 - 06:58 PM

I ended up calibrating the temperature knob that was what the problem was




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics