Jump to content



Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Parts Search
Site Search

FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


To get started, click here.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

Maytag Neptune laundry problems MLE2000AYW

MLE2000AYW Maytag Neptune stack

  • Please log in to reply
No replies to this topic

#1 Hal Paddock

Hal Paddock

    Unsui

  • Grasshoppah
  • Pip
  • 1 posts
  • Location: USA
  • Flavorite Brew:beer

Posted Today, 12:38 PM

Hi,

Some background(posted elswhere);

1rst problem; stopped just before each spin...nudge forward 1 click-goes through to next cycle-nudge, and on and on.

    Had insurance..so repairman replaced timer..left...Didn't even try it(New Years Eve).

    Tried to do a load..no change, same problem.

    Tried another load and all hell broke loose. Now water runs continuously as in rinse cycle. will not shut off unless I open door. Tried several cycles with door open and close button actuated. Water will not shut off unless I release door close button.

    Gave up, called repairman back..replaced timer again(7 days later), also control board in front panel. Still the same. He gave up..called Whirlpool tech, they told him it needs main control panel(located in dryer cabinet). Ordered part and left.

    On day of next service(6 days later) I got a call from Ins saying repair not cost effective so they are sending me a check for $348 replacement/buy back clause.

    So here I am, mechanically able to repair myself if viable. I would appreciate any and all advice/instructions/possibilities.

 

 

So...this led to replacing main control board. Worked fine for about 5 loads.

 

Now on this load it appears pump is not running. Went to get finished load out and was still wet(some water in bottom). Tried several different spin/empty cycles. Timer advances, tries to spin but spin shuts down. Washer stays on, but won't spin(keeps trying). Loud hum like motor trying to start(pump?). Or could be malfunctioning circuitry hum. Looking for troubleshooting info.

Any ideas?

Thanks,

Hal



Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!





2 user(s) are reading this topic

1 members, 1 guests, 0 anonymous users



FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics