Jump to content



Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Parts Search
Site Search

FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


To get started, click here.


Already a member of Appliantology? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Photo

Electrolux FS FGEF308TNFB Code:68 Part 2


  • Please log in to reply
6 replies to this topic

#1 Anthony

Anthony

    Ikkō-ikki

  • Chief Appliantologist
  • PipPip
  • 26 posts
  • Location: USA
  • Flavorite Brew:Dark & Tan

Posted 18 March 2015 - 12:42 PM

I found an article about the same model #, same conditions.  They had a crew of Frigidaire techs & electricians.  They replaced the control 3x & touchpad once (?).  Frigidaire put an inline filter on the block, but it doesn't say if that corrected the problem.   CK1402 is a bulletin related to electrical noise problems, doesn't include my model # though...  Will continue to search>>>



Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 Spannerwrench

Spannerwrench

    Mutsuhito

  • Appliantology Fellow
  • PipPipPipPipPip
  • 1,145 posts
  • Location: USA
  • Flavorite Brew:Maxwell House > Black Crown > Crown Royal with Ginger Ale

Posted 18 March 2015 - 01:23 PM

I had one of these that kept having problems a couple of weeks ago.  We've been replacing the board for various reasons, contently heating in the small oven, sometimes the light doesn't work, sometimes the clock resets or doesn't keeps time, and the last one shuts down during cooking.  I called tech line to see if the pointer also applied to this model since it's similar, they said yes they just haven't updated the service pointer.  They haven't updated the control kit part number yet either for this model, so you have to replace the control and filter board separately.  I've got the number written down somewhere I'll try to find it.

 

By the way the manual I posted does not apply to this model.


"Suds are not good"
"They write directions for a reason"
"Make sure you're using it right before you say it's not working correctly"
"If if has a Diagnostic Test Cycle, Run it before and after you fix it!"
"Doing the same thing over and over again and expecting different results is insane"

"For every complex problem there is an answer that is clear, simple, and wrong."
"Occam's Razor 'the simplest answer is most often correct'"


#3 Spannerwrench

Spannerwrench

    Mutsuhito

  • Appliantology Fellow
  • PipPipPipPipPip
  • 1,145 posts
  • Location: USA
  • Flavorite Brew:Maxwell House > Black Crown > Crown Royal with Ginger Ale

Posted 18 March 2015 - 01:37 PM

Here's the filter board part number, Electrolux also recommends replacing the electronic control at the same time.

Part number: 316303501

Part number: 316303501


Edited by Spannerwrench, 18 March 2015 - 01:38 PM.

"Suds are not good"
"They write directions for a reason"
"Make sure you're using it right before you say it's not working correctly"
"If if has a Diagnostic Test Cycle, Run it before and after you fix it!"
"Doing the same thing over and over again and expecting different results is insane"

"For every complex problem there is an answer that is clear, simple, and wrong."
"Occam's Razor 'the simplest answer is most often correct'"


#4 Anthony

Anthony

    Ikkō-ikki

  • Chief Appliantologist
  • PipPip
  • 26 posts
  • Location: USA
  • Flavorite Brew:Dark & Tan

Posted 19 March 2015 - 01:16 PM

One of the other techs ran the callback while I was out.  He switched L1 & L2 (??, heck, why not...)  No word back, been 4days, maybe the customer gave up (??)  I'll call them this week & check how things are working.

 

Nice networking guys.  I appreciate the effort :thumbsup:.  I figured it was a engineering glitch they hadn't caught up to yet. 

 

Thank you for the part number.  I'll get the filter, control & a prayer for these people. 



#5 Anthony

Anthony

    Ikkō-ikki

  • Chief Appliantologist
  • PipPip
  • 26 posts
  • Location: USA
  • Flavorite Brew:Dark & Tan

Posted 23 March 2015 - 10:05 AM

Called customer, still acting up.  Will install fix & post.



#6 Anthony

Anthony

    Ikkō-ikki

  • Chief Appliantologist
  • PipPip
  • 26 posts
  • Location: USA
  • Flavorite Brew:Dark & Tan

Posted 14 April 2015 - 11:58 AM

Still waiting for customer to schedule.  Go figure.



#7 Anthony

Anthony

    Ikkō-ikki

  • Chief Appliantologist
  • PipPip
  • 26 posts
  • Location: USA
  • Flavorite Brew:Dark & Tan

Posted 29 April 2015 - 10:29 AM

Installed harness & board a week ago.  Called customer last night.  All is good.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics