Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Caloric Pilotless Wall Oven not working


  • Please log in to reply
9 replies to this topic

#1 Lurker_Ovenless_*

Lurker_Ovenless_*
  • Lurking at the Threshold

Posted 24 May 2005 - 04:16 PM

Here's the deal.  My old Caloric Pilotless Wall Oven model RWP216 - the one with the meat probe and the analog timer.   I see them everwhere - they must have made a zillion of them.

The ceramic ignitor glows orange but no gas comes through the burner.  It acts as if a thermocouple isn't allowing the valve to open but I can't find a thermocouple. Not sure if its somehow built-in to the ignitor.   Anyway the themperature controller and light seem to work.  It calls for heating when the dial is set for a temp above the warmth caused by the ignitor running.

Do you think its the ignitor and if so, how do I test?  I have it out and can check it with a meter.   Alternately, do you think it could be the square gas valve looking thing on the right side behind the face plate?  I think this would not allow gas to flow if the two wires coming out aren't completing a circuit.  Can I jump these as a test?

Thanks.


Use the Appliantology Parts Search Box to Find What You Need!
Enter your model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

#2 Lurker_Ovenless_*

Lurker_Ovenless_*
  • Lurking at the Threshold

Posted 24 May 2005 - 06:11 PM

Let me clarify.    

-the light that works as expected is the indicator light.  (The oven light works too.)

- the square gas valve looking thing that is a suspect is a "safety valve".

- there is a thermocouple in the cooking comparment to keep the oven at the setpoint.  When I meant I couldn't find a thermcouple, I meant at the burner.  I guess I was thinking along the lines of a water heater. 

Anyway, any thoughts?  How do you test the safety valve?  Jumping the leads did NOT have any effect.  

Thanks.

#3 Budget Appliance Repair

Budget Appliance Repair

    Sensei

  • Appliantology Fellow
  • PipPipPipPipPip
  • 4,676 posts

Posted 25 May 2005 - 02:41 AM

Can almost guarantee you that the ignitor is bad. If ignitor glows, (but only bright orange look, not almost white hot), then the ignitor isn't drawing enough amps to open the safety valve.

The only way to know for sure is to use an amp probe and see the amp draw of the ignitor. If the ignitor at least glows you know the safety valve has continuity and also the t-stat and that it's most likely getting 120volts as needed.

The thing that you are calling a thermal couple in your oven cavity is the oven t-stat sensor that senses the heat in the oven and tells it when to turn on/off.

This should be the ignitor for your oven: CLICK HERE

And, about jumping the leads on the safety valve, I don't know what you did or mean by jumping the leads but if you sent 120volts direct without the ignitor in the circuit you have fryed the safety valve also. If you have fryed the safety valve the ignitor will no longer glow, so if after whatever you did the ignitor is still glowing your safety valve should still be ok.
William Burk (Willie)
Willie's Budget Appliance Repair
Eureka, CA 95501

#4 Lurker_Ovenless_*

Lurker_Ovenless_*
  • Lurking at the Threshold

Posted 25 May 2005 - 03:08 AM

Thanks for the response.

Yep.  That's my ignitor and it glows a very bright orange but I wouldn't say white.  How many amps should the ignitor be pulling?  Should it be tested when its on and hot?  

I did use a jumper as a test to connect the two wires coming out of the safety valve thinking that if I closed that circuit it would open the valve and allow gas to flow.  The good news is that I reinstalled the ignitor and it still glows bright orange.:)

Thanks again.  I'll definately be ordering what I need from you guys.


#5 Samurai Appliance Repair Man

Samurai Appliance Repair Man

    Shōgun

  • Fermented Grand Master
  • 28,805 posts
  • Location: USA
  • Flavorite Brew:Sapporo Original Draft Rice Lager

Posted 25 May 2005 - 04:42 AM

[user=0]Ovenless[/user] wrote:

  How many amps should the ignitor be pulling?  Should it be tested when its on and hot?  

 

See this page for more information and specifications on these ignition systems.


#6 Lurker_Ovenless_*

Lurker_Ovenless_*
  • Lurking at the Threshold

Posted 25 May 2005 - 02:47 PM

You guys rock!!

This was exactly the info. I needed.  My ignitor drew slightly under 2amps instead of the 2.5-3.0 amp specification.  Glad I didn't become one of those boneheads you refer to in your repair revelation and waste money replacing the valve.

I placed the order with you guys.    Thanks.


#7 Samurai Appliance Repair Man

Samurai Appliance Repair Man

    Shōgun

  • Fermented Grand Master
  • 28,805 posts
  • Location: USA
  • Flavorite Brew:Sapporo Original Draft Rice Lager

Posted 25 May 2005 - 02:55 PM

:rocker:

#8 Charred

Charred

    Unsui

  • Grasshoppah
  • Pip
  • 1 posts

Posted 01 August 2006 - 12:20 PM

Hi, I have the same problem and will be replacing the Igniter on my Caloric Pilotless Oven RXP216.

My igniter looks like this: http://www.repaircli...sp?R=154&N=2198

My question is, to replace the long ceramic igniter, do I have to access the rear of the oven where there appears to be a removable access cover or do I take apart the heat shield and just pull the old igniter out through the front of the broiler and then just attach and slide the new igniter into the back wall of the broiler and reassemble the heatshield?

Thanks for your help!

 

 


#9 AccApp

AccApp

    Sensei

  • Appliantology Fellow
  • PipPipPipPipPip
  • 1,790 posts

Posted 01 August 2006 - 05:31 PM

You should be able to pull it out from the front, just be sure to shut off the electric power before you take anything apart. I find lots of older stuff wired with reverse polarity, still works fine but will bite you when you get into it.
"When you have eliminated all which is impossible, then whatever remains, however improbable, must be the truth." Sir Arthur Conan Doyle.


http://www.fixitnow.com/beerfund.htm

#10 Lurker_ragemonster_*

Lurker_ragemonster_*
  • Lurking at the Threshold

Posted 24 June 2008 - 12:57 PM

hello i'm also having a problem with my oven, the igniter turns on orange but the oven doesn't get hot.  what would be the problem and how would i fix it? please help




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics