Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Pro Car Washer

Kenmore 70 Series not draining

6 posts in this topic

I bypassed the lid switch like I read on here and I even manually made the solenoids activate the  drain pump and it wouldnt hold and sometimes locked up the belt. I would run the belt to free it up and it would agitate again. But still no draining. Any ideas?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Without a model number not sure what you are talking about but if this has a belt ,by-passing the lid switch would not have anything to do with draining.  The lid switch in the belt driven only come into play for spin, but the washer has to drain before it will spin, will not spin with water in the machine. You have a bad water pump sounds like on this at least 20 year old washer.  Might help to ask before starting to follow advise on other styles of washers??  Activating the agitate and spin coils manually is a sure way to lock up the transmission... ;)

Share this post


Link to post
Share on other sites

Thanks. It is a 1984 model. Looks like its time for a new one.

Share this post


Link to post
Share on other sites

Replace that pump, belt and the wig-waq while your at it, just enter the make and model # at the bottom of this page and the parts will arrive quicker then a flick of a squirrels tail

Share this post


Link to post
Share on other sites

Pump was $42 and its working like new. thanks for the help.

Share this post


Link to post
Share on other sites

Welcome...........;)

Share this post


Link to post
Share on other sites