Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn appliance repair at online the Master Samurai Tech Academy.  Learn more.  Earn more.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

xtremtonz

Evaporative cooler works on Low but not on High

3 posts in this topic

Greetings,

My mom has an evaporative cooler from Sears. Model # 661626920. When it is on Low it works great. It does nothing once the switch is set to High. I'm thinking its the switch. Could it be the motor or something else ? Is there something I can check to see if it is the motor or the switch. The switch part is only 11.99 but I don't want to damage the unit during the hot weather cuz that would be very hard on my Mom.

 

Thanks

Tonz

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Hopefully, this can't be too difficult.  Just put a meter across your motor voltage and throw the switch to High.  If you lose voltage, then the switch is a pretty good place to start.  Of course there is always the possibility of a broken lead between the switch and the motor, but I'd rule out the switch first. 

Share this post


Link to post
Share on other sites

well I aint ever worked on an evap cooler but I would say that you hava a coomon post with a lead coming in from the power supply cord ans you have a L1 lead coming from the power cord and then you have a black wire and a red wire for high and low. check between L1 and the black wire  with the switch turned to high and see if you have continuity . and in order to get a coorect reading without a false loop remove the L1 wire. Be sure to unplug the dang thang beforehand:yikes:

Share this post


Link to post
Share on other sites