Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn how to be your own tech line…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
pkwyman

Whirlpool Dryer

6 posts in this topic

 My whirlpool duet dryer will not start. When the start button is pushed the time remaining display goes to "- -". I have tried unplugging it and turning the breaker off and then back on (Even though they are both basically the same thing), and pressing and holding the "end of cycle" button and it still won't work. Any other ideas on what it could be?

pkwyman

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

I just saw it was a dryer, will re post..

Share this post


Link to post
Share on other sites

Did you ever figure out what that - - error was on your duet? I'm having the same problem and can't seem to find anything on it, and of course the wife is pissed. Somehow this must be my fault.

Share this post


Link to post
Share on other sites

The problem turned out to be a shorted front panel. The repair guy had to call his parent company who in turn had to call whirlpool. Easy to replace yourself but unfortunately $315 for the part. would have been another $92 to have the repair guy come out to replace the thing so I did it myself.

Share this post


Link to post
Share on other sites

Thanks! I unplugged the dryer and it now seems to be working OK, with the exception of a quiet beeping noise when it runs. Did you have the beeping noise too?

Share this post


Link to post
Share on other sites

I didn't have the beeping noise. Mine simply quit working and gave me the double dash indication. I'm glad yours reset with power shut down. Mine would not.

Share this post


Link to post
Share on other sites