Jump to content



Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Parts Search
Site Search

FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


To get started, click here.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


Mr. Happy

Member Since 04 Oct 2008
Offline Last Active Sep 17 2014 09:34 PM

Topics I've Started

Kenmore refrigerator 596.76592600

25 August 2011 - 01:20 PM

Cold box is down. Fan is running, compressor is cool after two minutes of running.
No strange noises
All lights and internal fans running.
Evaporation pans below compressor and fan have what looks like used, baked motor oil in them.

Anything I might check before clicking RegPat_Off's fridge deal of the month?

WPGT9350C0WW

04 October 2008 - 07:30 AM

I have offered my love to the Samurai, now I beseech his wisdom on my path to washer enlightenment. Hai!

The error in the description field is on the washer display. Power off/power on = no good. Nothing else to report.


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics