Jump to content


Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


pebble

Member Since 26 Feb 2011
Offline Last Active Apr 13 2012 10:02 PM

Posts I've Made

In Topic: Bosch Wall Oven HBL8450UC/07 Clock speed

13 April 2012 - 06:44 PM

Ok -- chock this up to 'try before more troubleshooting'. Just "for grins" I went to the breaker panel and turned the oven breaker off, waited a couple minutes, and then turned it back on. Well, now it's back to keeping the time exactly correctly. The speed-up factor (10m in 6m real) kinda implies it might have had something to do with US 60Hz vs Euro 50Hz, but it would seem odd to not be using an internal crystal clock oscillator to base the time on. Regardless - it be fixed...

In Topic: Requesting manual for Bosch HBL8450UC/07 Wall oven

11 April 2012 - 11:56 PM

Thank you kind sir. Unrelated to the Bosch - I had to rebuild our Asko W660 washing machine (had a parts machine I got for cheap) and that all works fine. There's that cliche about things happening in 3's, so for us it was ceiling fan, oven, and washing machine. Your service with the info has been well worth the lifetime membership fee. Thanks again.

In Topic: Asko T760 Buttons won't respond

27 February 2011 - 11:19 AM

So... I leave it sit all open overnight and then this morning - seeing the parts laying in the laundry room - decide to check it again 'just for grins'. Well, buttons responded fine so I reassembled the dryer and it still responds appropriately. But I didn't really change anything so it more seems like either a trace that is intermittent or some component on the edge of failing. Has anyone seen these symptoms? Is this purely isolated to the display/control board? Thoughts?

thanks,
--pebble


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics