Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Boot Camp | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


jmm

Member Since 10 Jul 2006
Offline Last Active Jan 05 2014 10:27 AM

Topics I've Started

Kenmore 106.52532101 Fridge - squeaky noises

04 January 2014 - 12:41 PM

My fridge is working well but has started to make an odd noise occasionally - kind of a hum for 10 sec or so and then a squeaky noise. It seems to be coming from the freezer compartment. Any ideas - impending doom? Wait it out until something really breaks? Thanks....


kenmore 106.52532101 not cooling

18 October 2013 - 09:03 AM

I'm following the flow diagram and both compartments are warm (fridge was 50 and freezer was 39), condensor fan is running, condensor is clean, compressor is not running. How do I tell if there is voltage at the start relay? Its tucked in tight and I have to cut a zip tie to get it out - which leads to check and what should they read? I havde the parts diagram and cant find the cold control and muthaboard - other names? I feel like I'm getting in over my head....


Kenmore 110.62802101 Dryer - Doesnt start

03 June 2013 - 05:42 AM

Dryer was working last night - wont start this morning. Checked breakers - theyre fine - light bulb in interior is working. The push switch feels a little sticky. Any suggestions on where to start diagnostics? Thanks.


Panasonic MC-UG471 00 Vacuum - loss of suction

11 May 2013 - 08:46 AM

This has been a good machine but has lost alot of suction recently. Replaced the bag, inspected hoses, removed HEPA filter, etc - no success. Sounds like its clogged somewhere. Any ideas?


Kenmore 110.24862300 grinding noise

20 November 2012 - 02:41 PM

Grinding noise when the motor is running - no movement of agitator or during rinse cycle. Water flow in and out is OK. Suggestions for diagnostics?

Thanks...


FAQs | Store | Memberships | Repair Videos | Boot Camp | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics