Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


AvanteAppliance

Member Since 21 May 2011
Offline Last Active May 15 2012 07:56 PM

Topics I've Started

Maytag Neptune Dryer MDG5500AWW short flame cycle

05 May 2012 - 01:51 AM

Hello,
I have a gas maytag dryer model # mdg5500aww, the flame shoots long N strong and down to get the friction on, the igniter glows real bright too, replaced the coils, replaced the thermal fuse and ohmed the radiant sensor. Problem is: the flame lasts about 10-20 seconds and it takes hours to dry a load. I am guessing its either the control board, the actual valve, or maybe the cycling thermostat. Any ideas bros in appliance repair?

Kenmore Model # 417.44092500 No Spin

18 April 2012 - 11:41 AM

Hello,
I am working on a Kenmore Model # 417.44092500, when i select the drain/spin option on the dial and hit start, the pump is actuated and starts to pump and the timer runs down, then it starts to tumble, first to the left and then to the right. It does this for about a minute or more, then it shuts off, timer display goes black and then starts to beep very angrily with no tub action whatsoever. I already switched out the motor control board being that was what I thought was wrong, turns out the diagnoses is wrong. I am guessing its either the main control board or the door lock mechanism. Any suggestions? Thank you.

I WANNA BE THE SUB ZERO HERO! 632/S EC 24 ERROR CODE!

13 January 2012 - 04:01 AM

Subzero 632/S EC 24 error code and "service" flashes on console. The evap coil is already at the customer's house. I vacuumed the condenser coils as per instructed on Z Youtube.com. EC 24= Defroster underheat. What should I do next? What should I ohm/check? Thanks! I WANNA BE THE SUB ZERO HERO!!!

FAV6800AWW Controls Work but no output......

06 January 2012 - 02:38 PM

Hello, I just wanted to get a second opinion on this NEPTUNE TL FAV6800AWW. All the push buttons on the console work and all of them light up, door latch locks, and you can put it into any function you want, but when you hit start, nothing happens it just sits there doing nothing in the current cycle. No error codes whatsoever. I tried to service cycle to spin test and it acts like it wants to from the control end, but there doesn't seem to be any output to any of the other systems. My guess is the control board due to non existent output. Anything else I should check? There isn't a leak for the machine. Thanks for your input!

Suspension Spring Attachment Point has broken can it be repaired via JB Weld or epoxy?...

01 January 2012 - 04:39 AM

Can it be repaired? The only other way is to replace the outer tub which costs hundreds of $$$, not thats a lot nowadays but could we repair it? It would save my client so much money being that they're not doing too well right now..... machine works fine asides from that......


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics