Jump to content



Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Parts Search
Site Search

FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


To get started, click here.


Already a member of Appliantology? Just sign in with your username and password in the upper right-hand corner of the screen.

 


rudyh

Member Since 26 Jul 2006
Offline Last Active Apr 21 2015 01:17 PM

Topics I've Started

Whirlpool wfw9050 code 61

30 October 2014 - 01:05 PM

What is a code 61 on this washer?  What do I need to check?  A service manual or tech sheet would be appreciated.

 

Thank You


Fridgidaire FRS26H5ASB8 evap fan cycling

05 September 2014 - 11:12 AM

This SxS reefer evaporator was heavily frosted.  The evap. fan cycles on and off every few seconds.  The defrost heater is not open. The heater gets hot when fridge is placed in defrost mode. The evaporator fan motor and terminator were replaced.  Same problem few days later.  The damper motor was grinding so it was replaced.  The only remaining item is the ADC board which has not been replaced yet.  There is nothing else left!  Any suggestions would be appreciated.

 

Thanks


Fridgidaire SxS FSC23R5DB9: cant change temperature setting

03 August 2013 - 08:58 AM

I have a Fridgidaire SxS FSC23R5DB9 reefer that beeps when I try to change the temperature settings but the numbers dont change.  Is there a lock to prevent changes on this machine or what has failed, display board or main control board?   This has a single digit display for freezer and ff side.

Any help is appreciated.

 

Thanks

Rudy


GE Arctica SxS error codes.

08 October 2012 - 04:20 PM

I have a GE Arctica SxS reefer, gshf6kgzbcww. It is not cooling the fresh food side-all cold air passages are open, evap. fan is running, defrost system works fine. I ran all steps of the diagnostic. All tests pass except for the first 2 tests.
The first is freezer=0, reefer=2: "temperature control panel to main control board communication" returns: 61 22 instead of P or F.
The second is freezer=0, reefer=3: "temperature control panel to dispenser board communication" returns: 64 6 instead of P or F.
The third is freezer=0, reefer=4 which returns a P.

Is this indicating a failure in the temperature control panel or the main control board?

Please help.

Thank you
Rudy

Maytag mhwz400tq00 lights flashing when start is pressed

05 June 2012 - 12:11 PM

The machine flashes various lights on front panel when the start button is pushed but it doesn't start a cycle. The alpha numeric display flashes a bright "5" and a dim "4" and then a normal intensity of "54". This repeats at a 2-3 times /second rate. I'm thinking a bad capacitor on the machine controller. The machine goes through the automatic diagnostic without problem. Hard to believe it is in the control panel. The motor runs fine.
Any suggestions would be appreciated.

Thanks
Rudy


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics