Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Boot Camp | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


SPYDA

Member Since 22 Aug 2011
Offline Last Active Nov 12 2012 04:13 PM

Topics I've Started

GE WJSR4160DAWW

12 November 2012 - 12:14 PM

When you turn washer on and its on cold/cold water valve hums. Switch to other temps and it starts to fill, after filling no agitate. Turn to drain and spin and it drains and spins out. Water valve,preasure switch,temp switch all ok. Timer perhaps??

Viking VGRT360-6BSS

10 November 2012 - 11:54 AM

This is a 6 burner gas cooktop. Turn on front middle and the 2 right side ignitors click and dont stop. Turn on back middle and the 2 left side ignitors click. Turn on all 6 burners they all click. While all 6 are on i can turn off back middle and right front no more clicking, all others stay lit. Have replaced one spark module and all 6 valve switches, still same problem. Any thoughts of what it might be??

Viking Cooktop VGRT360-6BSS

17 October 2012 - 12:14 PM

This is a 6 burner cooktop. Turn on middle front and the 2 right side igniters are clicking . Turn on either one of right side burners and middle front and other right burner clicks. I was thinking to replace all 3 valve switchs and the spark module? Does anyone think this is the right thing to do???

GE WJRE5550K2WW

01 October 2012 - 10:49 AM

Machine wont agitate or spin. Replaced inline thermal fuse up by lid switch, also replaced control board at timer, still same thing. The flashing light on board on motor is flashing regular not giving me any error code. Tried to reset machine, still nothing. Motor does not hum or make any noise. Also shifter test good. Replace motor?????

Hotpoint HDA2000Z04AD

12 September 2012 - 01:23 PM

Thanks for the reply this morning by the way! Monday this dishwasher filled with water then would not run. Impeller was stuck so i kick started it and it ran. Now it runs but no water filling until i put it on water saver. Then it adds a little water then pumps it out, does this about 3 times. But still wont fill up.... Bad pump???


FAQs | Store | Memberships | Repair Videos | Boot Camp | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics