Jump to content



Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Parts Search
Site Search

FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


To get started, click here.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


medrison

Member Since 31 Aug 2011
Offline Last Active Sep 01 2011 01:38 PM

Topics I've Started

Maytag Neptun MDG3000AWW

31 August 2011 - 08:35 PM

My dryer is blowing only cold air, so I opened the front cover and did some testing and measurements. When I turn the machine on, it rolls and the igniter gets really bright but no flame or fire on the burner, and then after a few seconds the igniter turns OFF. I removed both solenoids and they measure - the big one 650 ohms and the small one 1.3 kohms - kind of OK. I measure the voltage at the solenoids plugs. After I turn ON the machine, the big solenoid gets 120V untill the igniter turns OFF when the small solenoid gets 120V. I installed them back and checked the sensors. Both measure 0 ohms conductivity. Still the burned does not start. I checked the panel settings, the outside gas valve, all OK.
What else can be wrong?

Thank you,
Mike


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics