Jump to content



Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Parts Search
Site Search

FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


To get started, click here.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


pope

Member Since 22 Sep 2011
Offline Last Active Nov 04 2014 12:30 PM

Posts I've Made

In Topic: Kirkland (Whirlpool) SGDX600HQ0 Low/Inconsistent Heat, Auto Dry Doesn't A...

04 November 2014 - 11:53 AM

Hi Eric, no fault on your part, I was just reading too fast.  Anyway, the dryer is now drying clothes in the normal amount of time in Time Dry mode, so those coils were probably going bad.  We are going to test Automatic Dry later today to see if that has started to work again.  Thanks for all your help.


In Topic: Kirkland (Whirlpool) SGDX600HQ0 Low/Inconsistent Heat, Auto Dry Doesn't A...

03 November 2014 - 11:58 PM

Well, my reading comprehension was poor on your first post, I think the ignitor and flames may have been operating correctly even before I replaced the coils, because I don't remember seeing the ignitor glow and go back out without the flames ever coming on.

 

Right now I get the glow and the flames on startup.  After a few minutes it goes dark.  A little while later I get the glow and the flames again.  I assume this is normal operation?  We've got a load in the washer now, so hopefully in an hour or so I can have results on dry time.


In Topic: Kirkland (Whirlpool) SGDX600HQ0 Low/Inconsistent Heat, Auto Dry Doesn't A...

03 November 2014 - 11:29 PM

I got the coils and put them in.  The glow and flames fired up quicker than before, but sure enough after several minutes they went away, and then came back on.  I guess that wasn't the culprit.  I suppose at this point I replace the Cycling Thermostat?


In Topic: Kirkland (Whirlpool) SGDX600HQ0 Low/Inconsistent Heat, Auto Dry Doesn't A...

01 November 2014 - 07:28 PM

Wow thanks that is what I'm seeing.  Turn washer on, 30 seconds later I hear a click and the ignitor glows.  A few seconds later another click and I see flames.  A few minutes later it is totally dark in there and the process starts again a few minutes later.  I had no idea how people were seeing the ignitor in their posts, didn't realize the access window was there.  Thanks very much, will pick up the coils.


In Topic: Maytag HAV2557AWW Washer - Grinding Noise

27 September 2011 - 12:58 PM

I wanted to follow up on this post and thank you for your help. Looking at the $175 in parts to get this into tip top shape, and the likelihood that the the transmission will be the next to fail, plus the insistence from my wife wanting to reliably get baby clothes clean, have led me to move onto buying a new machine instead.

As a token of appreciation for your help I bought a mug of beer at the United Samurai Fund. The timer, motor, or other items may be of some value, if there is anyone on here who buys such things. Thanks.


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics