Jump to content


Use this Search Box to Find Appliance Repair Help Now
Need help finding your model number?
365-day return policy on all parts purchased here, even electrical parts that have been installed!


FAQs | Store | Memberships | Repair Videos | Boot Camp | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource for DIYers!

The world-famous Samurai Appliance Repair Forums


You can post a question and get repair help for FREE! Click here to get started.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


philmang

Member Since 19 Oct 2011
Offline Last Active Jan 27 2014 11:09 AM

Posts I've Made

In Topic: Miele Tumbel Dryer

05 June 2013 - 02:34 AM

any one help here guys . strangely silent on any tips.


In Topic: Removing websearch from google chrome

05 June 2013 - 02:31 AM

tried both downloads and rebooted after scans. however no difference the virus still seems to be present.


In Topic: Miele T7644C Tumble Dryer - dead control panel

24 February 2012 - 10:32 AM

Guys just wanted to close out this post. with a final thank you for all the help. The repaired PCB Board arrived back and the machine is now back functioning as normal. Many thanks once again.

In Topic: Miele T7644C Tumble Dryer - dead control panel

09 February 2012 - 01:52 PM

Hi Guys just wanted to say a thank you for all the help on this . Great to be able to get the manuals and advice. Suspected the control board and managed to get a company in the UK which repairs all kinds of PCB boards. An to my great relief they have managed to repair for a cost of £50 . A long away from close to €300 from Miele. I am just waiting to get the board back and hopefully that should be it. I will let you know if I am successful. Once again thank you for all the help.

In Topic: Miele T7644C Tumble Dryer - dead control panel

28 January 2012 - 10:00 AM

Have been checking further on the wiring diagram. I have found that 220V is present on the Control Board at connector ST1. It them goes through various components but I do not have it on the On/Off Switch. I can only conclude that I have a faulty Control board at this stage. I have attached a link with images of the control board in case anyone may have a flash of inspiration.

https://picasaweb.go...CJKL3JKNsruPrgE


FAQs | Store | Memberships | Repair Videos | Boot Camp | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."

The Appliance Guru | AppliancePartsResource.com | Samurai's Blog

Real Time Analytics