Jump to content



Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Parts Search
Site Search

FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


To get started, click here.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


OldYeller

Member Since 06 Dec 2011
Offline Last Active Dec 17 2011 06:24 PM

Topics I've Started

Blower Motor not Reliable in HEATING mode - ArcoAire GUG070A012N

06 December 2011 - 05:50 PM

Hiyall,

I have an ArcoAire GUG070A012N - it runs cold just fine even though its 15+ years old, and the blower turns on every time when the cold cycle is on.

Problem is HEAT - the thing fires, the themostat kicks it on, the elements light up but then nothing happens with the blower motor. I can reach an in and spin the fan and it kicks on sometimes, but not always. It will typically run 4-5 cycles before it croaks again and I have to manually kick-start it.

Seems to me it's not the fan motor b/c it runs properly when the A/C is on, just not when the heat is on.

how else should I trouble shoot this?


FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics