Jump to content



Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Parts Search
Site Search

FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


To get started, click here.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


appliancecare

Member Since 04 Dec 2012
Offline Last Active Today, 02:27 PM

Posts I've Made

In Topic: Whirlpool Washer WTW8800YW0 Leaking

Today, 02:17 PM

I found a technical service pointer.  #:W10545059A  this addresses a bleach overfill problem on Cabrios but my model # is not listed,  Doesn't say anything about fab soft disp.  The service pointer says there is a new dispenser.  Should I just order and replaced the dispensers?  Also the customer has been using the machine on a cycle and selection that does not use these dispensers with no leaks... 


In Topic: Frigidaire dryer FSE48GFS0 thermal fuse

05 January 2015 - 10:21 AM

Correction on model #.  FSE748GFS0.  Thanks for all the replies.  I have replaced the front felt glide before. That's seems fine.  I have not changed the cycling thermostat.  I checked cycling temp at the vent outlet at the back of dryer.  Dryer thermostat seems to cycle fine and the exhaust/air flow is strong.  I haven't checked the motor by hand or the blower wheel I'm just assuming, because it runs quietly and exhaust fine, that these are okay.  I will try cycling thermo and check these other things and let you know.

 

Thanks, Jim


In Topic: Maytag Dishwasher MDB7709AWQ2 lights on/no run

27 September 2014 - 10:50 AM

Thanks for info.  Turned out that the control board was bad.  Ordered new board and installed. 

Thanks again.

 

Jim


In Topic: LG Washer WM2350HWC Washability

15 August 2014 - 05:44 AM

Thanks for all the responses.  I'll talk to my customer and find out and suggest these things.  I'll post my results.

 

But pretty much it can't be a fault of the machine?  It has to be user error?

 

Thanks


In Topic: Samsung Refrigerator RB1944SL/XAA Not Running

23 May 2014 - 04:36 AM

Thanks Durham and everyone.  Turned out to be a bad Thermal Fuse in freezer.

Thanks for all the help!



FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics