Jump to content



Learn appliance repair at the Samurai Tech Academy.  Learn more.  Earn more.


Parts Search
Site Search

FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Welcome to Appliantology.org, the Web's Premiere Appliance Repair Resource!

The world-famous Samurai Appliance Repair Forums


To get started, click here.


Already a member of the Appliantology Academy? Just sign in with your username and password in the upper right-hand corner of the screen.

 


appliancecare

Member Since 04 Dec 2012
Offline Last Active Nov 12 2014 02:03 PM

#294367 Samsung Refrigerator RB1944SL/XAA Not Running

Posted by appliancecare on 23 May 2014 - 04:36 AM

Thanks Durham and everyone.  Turned out to be a bad Thermal Fuse in freezer.

Thanks for all the help!




#283770 Maytag Refrigerator MFI2269VEA1 Water Dispensing Problem

Posted by appliancecare on 07 February 2014 - 09:41 AM

Thank you guys!  I will give that a go and let you know how I make out.

 

Thanks Again, Jim




#281905 GE Gas Range JGBP90MEB3BC Broiler not burning clean

Posted by appliancecare on 20 January 2014 - 05:27 PM

Update:

 

Went today and installed the new orifice.   WB28K202 with the green band.  Everything working fine.

 

Thanks for all the help!




#276431 Thank You For All Of The Help YOU Have Given Me!

Posted by appliancecare on 05 December 2013 - 07:32 AM

Great to see this post!   I own a small (1 man... ME!) appliance repair company.  I came across this site about 2 years ago I guess.   It has saved me banging my head against the wall many times!  Even with 30 years experience in this biz there are those times you need some help.  Manuals, tech sheets, part number and of course the occasional  "What the @#%& is this!" question.  I try to contribute to the beer fund when I can.  This post has reminded me to head over there and buy you guys a beer.  Great Job. Much Much Thanks!!!

 

Jim G.

Appliance Care

North Branford, CT




#271408 Maytag Washer MTW6700TQ1 F-71 Error

Posted by appliancecare on 18 October 2013 - 05:47 AM

FYI... I had to replaced the drive hub part # 280145 and bearing kit part # W10435302 to solve this problem.  Works fine now!  Turns out that it was stopping mid cycle and giving an OS code too. 




#253040 Woods Upright Freezer Frozen Drain Tube (again)

Posted by appliancecare on 25 April 2013 - 12:42 PM

Ive used the gh250 on some older models.  It works good.  I beleve you wire it in parallel with the evap fan motor so that when the unit cycles into a run mode the heater comes on to keep the drain from freezing.  I also use the GE wr2x9393 heat probe. Its basicly a flexable piece of wire that you stick down the drain line and then wrap it around one of the evap coils next to the defrost heater.  U can then form the wire to run next to the defrost heater, glass or calrod. The wire will conduct heat from the def heater when it goes into def cycle.





FAQs | Store | Memberships | Repair Videos | Academy | Newsletter | Beer Fund | Contact


Use the Appliantology Parts Finder to Get What You Need!
Enter a model number, part number, type of appliance, brand, or even a part description.
365-day return policy on all parts purchased here, even electrical parts that have been installed!

Your Sometimes-Lucid Host:
Samurai Appliance Repair Man
"If I can't help you fix your appliance and make you 100% satisfied, I will come to your home and slice open my belly,
spilling my steaming entrails onto your floor."


The Appliance Guru | Master Samurai Tech

Real Time Analytics