Jump to content
Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Subscribe to our YouTube channel for lots of appliance repair tips and help! Subscribe to our MST Radio podcast to learn secrets of the trade. Sign up for our free newsletter and keep up with all things Appliantology.

Search the Community

Showing results for tags 'bake'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Appliantology Welcome Center
    • Kendo Masters Hall of Fame
    • Site Orientation
    • Announcements
  • DIYer Appliance Repair Forums
    • DIY Appliance Repair Help
    • Find a Local Tech
    • Appliance Haikus
  • Appliance Service Manual Requests
    • Appliance Service Manual Requests Forum
  • Professional Appliance Technician Forums
    • Appliance Repair Tech Forum
    • Professional Appliantologist Webinars Forum
    • Samurai's Appliance Repair Video Classroom
    • Samurai’s Appliance Puzzles
    • The Dojo

Blogs

  • Samurai Appliance Repair Man's Blog
  • kdog's Blog
  • Mrs. Samurai's Kitchen
  • DurhamAppliance's Blog
  • applianceman97's Blog
  • LI-NY Tech's Blog
  • tpoindexter's Blog
  • Smashycomman's Blog
  • acfixerdude's Blog
  • Tech notes
  • Eugene's blog about stores, fixing, life, and more!
  • Moostafa's Hookah Tent
  • Son of Samurai's Blog
  • Quick's Blog
  • Beyonddoubt's Blog

Categories

  • Appliance Repair Manual Stash Access File®
  • Appliance Repair Manual Pot Luck Supper

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 3 results

  1. I am trying to troubleshoot our thermador RED30v all electric oven. The bake element is not heating, the broil will warm slightly for the pre-heat function but zero heat on the bake. The bake element tests about 30ohms. The Red wire from the back of the controller mark BA on the controller has 240 when in bake and there is 240v at the bake element. It seems there is no return path for the circuit. Can someone help me understand this circuit? With the oven off, I did a continuity test from the element to the controller, the red wire is good but I cannot determine where the other side of the bake element goes. Both wires are red at the element. Is the return path through one of the two relays? I've heard about these relays failing causing this same no Bake element heat symptom. I am mostly looking at the BR,BA,L1,COM and neutral pins. The thick black wire on post L1 seems to be power in, the thick red wire on post BA seems to be power out (energized when bake is on) on has continuity to the back element on one side. I cannot find a wire with continuity to the other side of the back element which is confusing me. Any help on this is much appreciated. Thank you. (
  2. File Name: Whirlpool Gas Freestanding Ranges with Direct Spark Ignition (DSI) Control Service Pointer: Spark but no Ignition File Submitter: Samurai Appliance Repair Man File Submitted: 25 Oct 2013 File Category: Appliance Repair Manual Pot Luck Supper Gas Freestanding Ranges with Direct Spark Ignition (DSI) Control All Code Dates Concern: Under certain circumstances the Bake burner may not ignite. Sparking is taking place but flame is not established. Cause: • Wiring harness may be pinched at a location between the Bake/Broil igniters and DSI Board. • DSI Board mounting bracket may be contacting a solder joint on back of the board. • Positioning of Igniter and gas burner igniter ports may be out of adjustment. • Igniter (Electrode) deterioration Technical Service Pointer #: W10622771 Release Date: October, 2013 Click here to download this file
  3. 75 downloads

    Gas Freestanding Ranges with Direct Spark Ignition (DSI) Control All Code Dates Concern: Under certain circumstances the Bake burner may not ignite. Sparking is taking place but flame is not established. Cause: • Wiring harness may be pinched at a location between the Bake/Broil igniters and DSI Board. • DSI Board mounting bracket may be contacting a solder joint on back of the board. • Positioning of Igniter and gas burner igniter ports may be out of adjustment. • Igniter (Electrode) deterioration Technical Service Pointer #: W10622771 Release Date: October, 2013
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.