Learn how to troubleshoot like a Master Samurai Tech...

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
  • Announcements

    • Samurai Appliance Repair Man

      Webinar Recordings Index Page   07/27/2017

      One of the benefits of your Professional Appliantologist membership is that you can attend the regular, live training webinars and you have access to the recordings as well. So if you can't make it to the live webinar, catch the recording at your convenience. The webinar recordings are conveniently listed for you on the Webinar Recordings Index Page.   
dave42

Jacuzzi Z112

Recommended Posts

dave42   
dave42

Request for Jacuzzi Z112 service manual

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

appl.tech.29501   
appl.tech.29501

Can't find a manual, but may be able to help. What kind of problem are you having?

Share this post


Link to post
Share on other sites
dave42   
dave42

We had a problem that the pump only runs on low speed. The pump/motor was replaced and then the switch/sensor that is attached to heater was replaced. Seemed to be working fine, then after 2 days, the same problem recurred.

When tub is plugged in (110 V), the pump/jets run at low speed, and heater light is steady red. When we try to increase speed, the motor makes a humming sound, and the light on the GFCI plug goes off momentarily. The pump then continues to run at low speed. The circuitboard was replaced about 2 yrs ago. We noticed some tarnish on the contacts of the power plug and cleaned that off, but that did not help. Thanks.

Share this post


Link to post
Share on other sites
RegUS_PatOff   
RegUS_PatOff

I don't know if this info will help, but it's all I could find.

Jacuzzi Spa Electronic Control System Troubleshooting Guide G647000 7-95.pdf

Jacuzzi Electrical Section 7348000E 4-97.pdf

 

 

Share this post


Link to post
Share on other sites