Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn how to be your own tech line…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
vman_fl

Magic Chef oven does not work

4 posts in this topic

My 5 year old electric magic chef oven (model # CER3540aaw) does not work.  The control panel has a 3 led display modes (temp, preheat, and lock).  The stove top does work, but when I hit the bake button the Lock led lights up.  I have tried the control lock-out feature (stop time and cancel at the same time) but that didn't work.  I reset the main breaker, that didn't work.  I checked the handle (used for the self clean operation) and that seems to be working fine.  The oven appears to work in the self clean mode.  One other unusual thing, any time I want to set the timer, I need to hit cancel before I can adjust the timer.   thanks -v

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

If neither the stove nor the oven work on this range, then you need to go back to the wall outlet and verify you have a valid 240v supply.

Share this post


Link to post
Share on other sites

sounds like a failure in the lock circuit, the control "thinks" the door is still in the locked position. if its the unit i think it is, there are 2 microswitches on the lock ass'y which is located toward the front of the stove under the cooktop- there is a small metal cover over them and they are suseptible to moisture migration and corrosion and one of the switches may have failed.

Share this post


Link to post
Share on other sites

The stove does work, just not the oven.  I did take off the metal cover for the lock mechanism, the switch for the lock makes contact when the handle is moved into position.  I was not sure what the second switch did, it did not appear to engage the lock arm in any way.  I had the power off, if that makes any difference.  When should the second switch come into play? 

Share this post


Link to post
Share on other sites