Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Tired of guessing on service calls?

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
chipwest

Frigidaire FEE368CCSD Range display blanks out

9 posts in this topic

This started about 2 weeks ago that when the oven is turned on the Electronic Oven Controler goes blank that show the oven functions. The oven does not heat up in any mode. I can redo the inputs several times with the same results. Has the EOC failed or do i need to look at other parts of the unit?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

More than likely. But need a valid model number to know for sure.

Share this post


Link to post
Share on other sites

FEE368CCSD

blink.gif My eyesight isn't as good as it once was (see RegUS_PatOff
)

but from here it looks like that model number may be

FEF368CCSD

not much info on that c.1995 model

Do the Top Burners work OK when the Oven Controller blanks out ?

Share this post


Link to post
Share on other sites

I am told the stove top works fine even thou the oven display goes blank. The clock stay on and the timer also works.

And you are correct, it is a FEF368CCSD

Thanks for the responses

Share this post


Link to post
Share on other sites

then just the "Temperature Display" goes blank ?

Share this post


Link to post
Share on other sites

Sorry for the confusion.. The whole dispaly goes blank.. then about 10 sec later it comes back up. time is correct.. timer does count down. The display goes blank with in milli seconds of putting the oven in use...

Share this post


Link to post
Share on other sites

so... when you try to use the Oven, the Display goes blank, but then comes back ON.

and keeps repeating ON/OFF ?

and all during this time, the Oven doesn't heat but the Top Burners still work OK ?

Share this post


Link to post
Share on other sites

As long as u engage the oven it goes blank and comes back in about 10 sec.. u can repeat as often as you like in this mode. and yes.. all the top burner work good and correctly....

Share this post


Link to post
Share on other sites