Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Lost with the new appliances? The Samurai teaches you Circuit Fu…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
lou

kitchenAid Washer no brakes!!

5 posts in this topic

Thanks for this very interesting forum!!

I have a KitchenAidWhirpoolKenmore washer, with direct drive. It has exactly 5 years and 28 days of service.

At the end of the spin cycle (or opening the lid) the basket simply doesn't brake anymore and makes some noise. I did some research on this forum and decided to go after the clutch assembly.

I removed the motor and brakets, removed the three bolts holding the transmission but it won't come off. It seem stuck in there (by pulling on it hard, it only slips out 1/2" or so). Should the transmission slips off easily??

Do you think I am on the right track?

Thanks

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Erm....you did remember to take the agitator off, didn't you? Quite apart from that, this may be yet another drive block issue. Bolt your tranny back into place, and take the agitator off. wp_dd_wash_drive_block.jpg?dc=4675466063395598024

 

Does it look exactly like this?

Share this post


Link to post
Share on other sites

Distinctly possible also.

Share this post


Link to post
Share on other sites