Learn how to troubleshoot like a Master Samurai Tech...

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
HeidiBeal

Ecowater ERO-R450E RO system

2 posts in this topic

We've had this unit 2 years and it has begun to leak from a couple different places in the housing. One place is an opening on top of the unit (postfilter end) within the wire strain relief. No idea what the purpose of this opening is. The other place it leaks is the seam along the back of the unit where the hanger bracket fuses to the body of the housing. I've disconnected the in and outflow tubes, examnied the auto shutoff assembly, replaced evey o-ring in those. It seems to leak only after the system has pressurized awhile . The housing has no sign of cracks or other wear. It must be coming back up through one of the sumps? I checked the collets and o-rings in the tubing. Didn't replace those o-rings..they looked fine and seems like if one them is letting water pass, I would see the leak coming from that port.

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now