Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Begin your journey to appliance repair mastery…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
bogreen

Kenmore Refrigerator Model #596.75523400

2 posts in this topic

Serial # 10853633GA

Hi,

This unit has an evaporator fan motor that won't run.

The customer ordered and replaced the motor and still no fan.

I replaced the "jazz board" today and still no fan.

Maybe there's a delay before the fan comes on like the old Amanas where the defrost

thermostat has to get down to temp first.

I had to get to the next call, so couldn't wait to find out. I'm sure the customer will call

tonight if it is still not blowing.

Anything else on this unit that could cause the evap fan to not run??

Thanks,

Bruce

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

The defrost thermostat is in series with with the evaporator fan circuit. If it's stuck open, the fan will never come on.

Check the defrost thermostat resistance when the thermostat is at room temperature:

Part link for the defrost thermostat ==> http://www.repairclinic.com/PartDetail/Defrost-Thermostat/67003426/1033990

Share this post


Link to post
Share on other sites