Isn’t it time to know what you don’t know?

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
Sign in to follow this  
Followers 0
ChuckFasst

Frigidaire: No water activation but do have ice FRS22ZGG

2 posts in this topic

At first it seemed like the switch was sticky. Hard to get water flowing and then not always shutting off right on time. Water flow became les and less and then stopped. When water dispenser switch is activated I feel the solenoid with the Yellow connector activate on the Dual Valve which is downstream from the first dual valve that the groundwater inlet hose is hooked into. There is no water on the other side of this one. It has one inlet and two outlets that immediately "T" together. Both of these valves have a yellow connector and a Green connector to their respective two solenoids. I believe the Yellow one (with yellow wires) is the water.

Shouldn't the yellow solenoid on this one also activate when pushing for water??? Seems like both of these yellow solenoids would have to activate in order to allow flow to the filter and then to the outlet. Am I wrong?

Frigidaire Side by Side Gallery Series FR22ZGG with filter replaced about 3 mos. ago but already looks pretty bad and could be mostly clogged possibly.

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

... FR22ZGG

I'm not sure of the Valve colors, but there is a "Dual Diode" that energizes the Main Water Valve

when either the IceMaker Valve OR the Water Disp[enser Valve is energized.

Also, your model number is missing (2) characters at the end

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0