Learn Circuit Fu, the ancient lost art of appliance repair…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.

Yet another Duet Sport HT WFW8400TW00 that won't drain

2 posts in this topic

When running any cycle washer doesn't drain and returns F21

When I run just "Drain and Spin" cycle I notice pump engages immediately (should it?) but doesn't drain anything.

I searched the forum and followed what I found here and others have tried:

Large Items trap has been cleared... $1.06 in coins, some hair ties, some twist ties, some broken glass (don't ask), and not a small amount of the usual "black crud"

Hoses have been checked for blockage... poured water down the hose and watched it come out of the opened pump housing

Pressure Switch has been reset

Pressure Switch hose was checked for blockage (I was able to blow into it)

Pump motor has been taken off, verified not blocked (or otherwise bound)

When I start the "Drain and Spin" cycle with the motor pulled out the pump blades spin. When I put the motor back in and start the "Drain and Spin" the pump blades still spin. When i close up the pump and turn the water back on, as far as I can tell the pump blades are spinning (vibration in the motor housing feels the same) and I can squish the hose from the drum and feel the water in it but none of it seems to make it up the hose.

One time during this testing I poured about half a gallon of water down the drain hose (trying to "kick start" it sort of...) and it didn't drain that either until near the end of the cycle when the pump seemed to suddenly kick into over-drive and did actually drain. After that I tried to run another normal load and back to F-22.

So I think I've narrowed it down to either the pressure switch or the pump needing to be replaced... how do I figure out which one is the real problem?

Share this post

Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Could be some debris causing a partial blockage in hose, otherwise you got a stripped pump impeller that slips under load (twist ties/broken glass) - remove drain hose and look through it or smack it on some concrete








Share this post

Link to post
Share on other sites