Learn Circuit Fu, the ancient lost art of appliance repair…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
repairguy1

Oasis washer model # 110.27086601

5 posts in this topic

During the "clean washer" cycle, which is the only cycle not working, the timer runs from 60 mins to 57 mins and then jumps to 2 mins and drains water and shuts off. No error codes displayed or in history.

Tub moves freely. Anyone encounter this or have any thoughts on what may be happening?

Any help appreciated.

Thanks

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

i had this once and this is what i noticed. when the cleaning cycle works properly it fill with some water and then spins the tub to slosh the water around the tub, then it fills to the top and adjatates. On the one that i had that was doing what u described it filled with too much water at first and when it went to spin the tub the basket had already floated up and it spun the impeler. it then went to 2 min, drain the water and shut off. I ordered a main control board but unfoutunetly i did not get the call back so i dont know if it fixed it. Hope it helps

Share this post


Link to post
Share on other sites

it's a known problem on some models, only a new main control will fix it.

Share this post


Link to post
Share on other sites

  1. thanks for all the help

Share this post


Link to post
Share on other sites