Learn how to troubleshoot using schematics like a real tech…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
  • Announcements

    • Samurai Appliance Repair Man

      [Webinar] Basic Refrigeration Sealed System Thermodynamics   09/21/2017

      See this calendar event for details:                   
    • Samurai Appliance Repair Man

      Webinar Recordings Index Page   09/21/2017

      One of the benefits of your Professional Appliantologist membership is that you can attend the regular, live training webinars and you have access to the recordings as well. So if you can't make it to the live webinar, catch the recording at your convenience. The webinar recordings are conveniently listed for you on the Webinar Recordings Index Page.   
tpoindexter

Kitchenaide Double Oven Range KDRP487MSS02 Manual needed

Recommended Posts

tpoindexter   
tpoindexter

I have a double oven, range that both the ovens are not reaching temperature. It has nine gas burners on top, and, the ovens are electric elements. Elements are getting 220 volts. Any thoughts on what the problem may be? I need the service manual before I tear into this one.

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

RegUS_PatOff   
RegUS_PatOff

.... Elements are getting 220 volts. Any thoughts on what the problem may be? I need the service manual before I tear into this one.

If the Elements are getting 220v, they'd be getting hot, unless they're bad.

How are you measuring 220v ?

Tech Sheet - 8302546.pdf

link PM'd

Share this post


Link to post
Share on other sites
tpoindexter   
tpoindexter

Sorry, I misspoke. I checked the power at the outlet and got 220 volts. Since I'm unfamiliar with the unit I wanted the service manual before I tore into it.

Share this post


Link to post
Share on other sites
RegUS_PatOff   
RegUS_PatOff

either a problem with the Thermal Fuses on the back wall of both Ovens

(self-clean used lately ?) :nono:

click on picture

Thermal-Fuse-9759242-00757521.jpg

OR

a problem with (red) L2 line power

Share this post


Link to post
Share on other sites
tpoindexter   
tpoindexter

It confused me because it was both ovens. When I get it out and apart I will check out the red wire. Thank You!

Share this post


Link to post
Share on other sites
tpoindexter   
tpoindexter

Thank you RegUs.

The fuses fixed this back in October. Just thought I'd update before making my next post.

Share this post


Link to post
Share on other sites