Troubleshoot modern appliances with confidence…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
jkirksey1889

Bosch Dishwasher SHE46C06UC/36

11 posts in this topic

Manual please.

Thing just keeps going. Time starts at 160 and when it gets to 1 minute left it just keeps running. Customer doesn't know if it's rinsing or cleaning the whole time and I didn't have 160 minutes to watch it. Thanks.

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Thanks

Share this post


Link to post
Share on other sites

There is something bad in the heater circuit or a bad control board.

The simpler way to check it is remove the front panel to expose the wiring. Start the dw. About 5 minutes into the cycle use a insulated jumper wire from the incoming power at the control board to the adjacent large RED wire. Your clamp on amp meter should be around the large red wire while doing this. No amps will be bad heater circuit component(s). 10.5 amps will be a bad heat relay on the control board.

Share this post


Link to post
Share on other sites

Take the board out of the plastic housing that it comes in, You will probably find a burnt solder joint on the back side of the board.

If you are feeling like an electronic engineer you can fix the bad solder joint with a small piece of wire but that will go bad sooner than later.

That solder joint is what feeds the heater, heater never comes on so dw cant finish with a dry cycle or the water never gets hot enuf to wash.

The board is most likely the problem... and the post above this works great too, thats the real way to test it. My way is my dad's old school way.

All my best

Vince

Share this post


Link to post
Share on other sites

It can be a bad solder joint but not always and this can trick people. If you're not getting the current draw that that Brother jumptrout described, then there will be one of two problems: open in the heater circuit (usually the NTC); or the control is not putting out 120vac to the heater.

It's easiest to check the control.

The control board puts out 120vac to the heater circuit on the red wire. If you're not getting the current draw through the heater, then check to see if the control is putting out 120vac on the red wire. If it is not, then the problem will either be 1) a burnt solder joint on the heater relay or 2) some other non-visible problem with the control board. I have seen the control boards fail in this manner WITHOUT the relay being visibly burnt, so you have to check for voltage the red wire to know what's going on.

The difference between the two type of control board failures is this: burnt solder joints are field repairable but the other types of non-visible failures are not.

Share this post


Link to post
Share on other sites

if you start the unit in light wash. the detergent cup should pop within the first few minutes of wash. Once that happens, the heater relay should close at or within 4 minutes. When I arrive on the call I start the unit in short wash and remove the toe panel and place the amp clamp around the black wire coming into the uinit. This also gives me a chance to check the wire nut connectors or terminal block whichever applies. By the time I get all this done and stand there shootin the breeze w the customer, the detergent door opens, wait 5 min and if the amperage jumps to 11 or so, I know the heater ckt is fine. If not, order the board and move on to the next call. Hope this helps.

Share this post


Link to post
Share on other sites

Thanks guys.

Share this post


Link to post
Share on other sites

Just an update. The control board was not putting out 120 to the heater and was visibly burnt. Thanks for the help.

Share this post


Link to post
Share on other sites

Glad you got it repaired.

Share this post


Link to post
Share on other sites

Just to comment on this issue, this is a very common problem with a wide range of Bosch dishwashers. The problem is the relay is undersized for the application. Many times people will tear the control apart, only to find the burned solder joint. This is secondary to the real problem, which is the contacts begin to fail, causing the reed of the relay to heat up so much that it melts the solder. At some point, enough solder is gone that on the next cycle - boom - and the heater no longer works.

I upgrade these boards with a relay suited for the current, and I beef up the related circuit board lands for the heater. To the best of my knowledge, Bosch has not changed their design, so buying a new board will provide the same results. Resoldering the bad place will eventually yield in a failed heater.

PM contact me if you want more info.

Edited by MrMark

Share this post


Link to post
Share on other sites