Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Tired of guessing on service calls?

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
SPYDA

GE WJSR4160DAWW

3 posts in this topic

When you turn washer on and its on cold/cold water valve hums. Switch to other temps and it starts to fill, after filling no agitate. Turn to drain and spin and it drains and spins out. Water valve,preasure switch,temp switch all ok. Timer perhaps??

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Check the sediment screen on the valve, back where the hose connects. If it's socked in with sediment, that's the problem. The valve may or may not be impaired as a result of the sediment. I run into this problem a lot and, personally, I always replace the valve because chances are fair that the sediment has gotten into the valve and the valve is now at risk for sticking open and flooding. And guess who gets the blame for that?

Valve part link ==> http://www.repairclinic.com/PartDetail/Water-Inlet-Valve/WH13X10024/1159233?modelNumber=WJSR4160DAWW

Water-Inlet-Valve-WH13X10024-00917432.jpg

Share this post


Link to post
Share on other sites