Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Troubleshoot modern appliances with confidence…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
AlexM

GE Refrigerator Model# PCF23MGWABB, Ice Auger Issues

4 posts in this topic

The ice maker is producing plenty of ice, when you go for crushed or regular ice cubes in the door the auger motor runs for a second then shuts off.  During this, for a fraction of a second the display flashes '0' and then stays blank. I checked the actual ice bin and the cork screw turns freely and I operated the auger without the bin in and the auger does the same thing. I suspect I need a new dispensor control board P/N WR55x10899 and or front panel P/N WR55X10861.  The front panel part number needs to be black,how can i confirm this?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

Maybe someone has the user manual? Thanks in advance.

Share this post


Link to post
Share on other sites

I don't have the service manual but can get the minimanual (basically, the schematic and specs) if that would help.  

 

Check the wire harness connector at the bottom of the freezer door hinge.  If wet, corroded or mangled, that'll be the problem.  

Share this post


Link to post
Share on other sites

Well I went back today and the home owner claimed that the auger works on occasion.  Didn't work for me.  I checked the wire harness at the bottom, cleaned it with rubbing alchohol.  Also checked the harness on the auger motor, seemed fine.  When I depress the ice dispenser lever on the front of the door, the flap opens, but nothing happening with auger motor.  When I switch back and forth between crushed ice and cubes, the cylinoid doesn't activate either?  Is this a problem in the front of the door?

Share this post


Link to post
Share on other sites