Tired of guessing on service calls?

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
Sign in to follow this  
Followers 0
ChipStix

Haier Dehumidifier model HDN305 won't start

3 posts in this topic

Hey guys - my 6 year old Haier dehumidifier (HDN305) would not wake up after it's 6 month winter nap - no lights, no fan, no compressior. After verifying it was plugged into a hot outlet (118v) I removed the cover and tested various aspects of the control board connections. The fuse is good and has power (118v). I tried running  with the humidity level/power on/off control in both open & closed states. I also tried the same with the bucket full control and what I think is a copper coil temperature monitor. No respondo in all cases.  Is there anything else to check or any definitive repair I can apply before I send it to the recycle center? 

TIA

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

What, no takers on the dehumidifer problem? Perhaps I should offer a case of Hitachino Nest White Ale as an incentive?

 

So I figured I'm on my own with this one, and after testing the peripheral stuff without any indications of faults, I go ahead and order a new Main Control board, which the Repair Clinic lists as part # AC-5210-149. But when it arrives it takes me about 3 seconds to recognize that it's not the same board that's in my belly-up machine. WTF?

 

Here's a link to a picture of my control board and I'm hoping someone can identify it and suggest the correct replacement.  http://sdrv.ms/19M9DHm

 

Or, if the board I have can't be found, is there a way that I can use the listed AC-5210-149 board in this machine?

 

Domo arigato

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0