Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Dumbstruck by the new computer-controlled appliances? Let the Samurai enlighten you…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
fgeric

Kenmore Dishwasher Mo. 665 Woes

7 posts in this topic

Hello all,

New to the group! So a couple weeks ago my dishwasher stopped working. I did some basic troubleshooting and discovered that the control module was bad. I replaced that and put it back together and everything seemed to be working, except the front panel didn't go together very well. About a week later it stopped working again. I took it apart and metered everying and discovered that the thermal fuse was bad and the connections on the door handle switch were loose, so I replaced that while i was at it (everything went together nice and tight this time). I put it all together and plugged it in. Now the lights come on. The cancel/drain button is working correctly, but the dishwasher doesn't seem to be filling with water and functioning. Any suggestions (besides call a appliance repairman)? When I switch it on I can hear it click on but no water fills, etc.

 

Thanks!!!

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

full model number ?

665.xxxxxxxx

Share this post


Link to post
Share on other sites

Sorry it's a 6651392k600

My eyesight isn't as good as it once was blink.png (see RegUS_PatOff http://www.youtube.com/watch?v=oPAY2LsKVEw )

but there seems to be a digit missing

66513x92k600

. . . . . . 4

. . . . . . 5

. . . . . . 6

. . . . . . 7

 

 

Share this post


Link to post
Share on other sites

I beg your pardon! My eyes are the ones that are questionable. The number should be 66513 592 K600

Share this post


Link to post
Share on other sites

Make sure the (5) pin Connector (P2) is connected on the Controller

 

Also, when replacing the Thermal Fuse, you must use the wires that are included in the "kit",

else the Fuse will blow again

Share this post


Link to post
Share on other sites

Good call sir! Pulled it and reattached it and BINGO!! Many thanks!!!!

Share this post


Link to post
Share on other sites