Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Begin your journey to appliance repair mastery…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
Magenta#90

Whirpool duet washer GHW9150PW3 "f11 and DL code

4 posts in this topic

I replaced the CCU relay's (3) for the F11 code, but still not responding, won't rotate now i'm getting "DL" code, how to test the MCU, this test was uploaded by Samurai on May 07,2013, I cannot locate. I disconnected the BLUE wire harness and try to start the machine seems to start but is not because the connector is off, doe means that the MCU is bad??? HElp.

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

It is in the appliantology gallery under washer repair; testing mcu in a whirlpool duet washer.

Yes, what you are seeing means you have a bad mcu according to the gallery post.

Share this post


Link to post
Share on other sites

gallery_4_5_80497.png

Share this post


Link to post
Share on other sites

Went back replaced MCU now is running, bad news the spider in the back is loose, so it may take couple of months before all come loose and she have to buy another F/l washer.

Share this post


Link to post
Share on other sites