Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Begin your journey to appliance repair mastery...

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
scconsulting

GE refrigerator troubleshoot help

30 posts in this topic

WOW you all are too technical when this happens the !st & easiest to check is Main Board,  pull out & look under main compressor relay it should be burnt or solder is tarnished.

 

Averages say 8-10 odds its the board.

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

WOW you all are too technical when this happens the !st & easiest to check is Main Board, pull out & look under main compressor relay it should be burnt or solder is tarnished.

Averages say 8-10 odds its the board.

In other words "here's your fish, now go away"

Lest you forget, this is a training academy. We are not here to answer and solve just one person's problem but to teach and share info to grasshoppers and masters alike.

Share this post


Link to post
Share on other sites

The main board looks pristine, the relay a little grungy but the terminals are clean at the connection area. As if now it's functioning correctly for about 14 hours. So at this point I'm going to monitor it and wait for the defect to present itself again.

Share this post


Link to post
Share on other sites

Leave it to the Appliance Gremlin  LOl.

Share this post


Link to post
Share on other sites

Did you pull the board and look at the back/trace side?  Front side can look fine and still have burnt/cold/broken solder connections.

Share this post


Link to post
Share on other sites