Need appliance parts? Call 877-803-7957 now or use the parts search box:

Parts Search

Learn how to troubleshoot using schematics like a real tech…

Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Samurai on Facebook - become a fan today! Sign up for our free newsletter and keep up with all things Appliantology. Subscribe to our YouTube channel for lots of appliance repair tips and help! Follow the Samurai on Twitter and get timely morsels of Appliantological Wisdom! Subscribe to our MST Radio podcast to learn secrets of the trade.
AnarchoV

Asko D3120 won't run cycle

4 posts in this topic

I am new hear to the forum. I have a Asko D3120 that won't run a wash cycle. I shut the door, select the program and hit the start button and everything run normally. The drain pump kicks on, the inlet valve opens and water pumps into the bottom of the washer, then it just shuts off. The cycle progression lights just completely turn off. If I hit the start button again, the drain pump kicks on (I can hear and see water exiting) then the inlet valve pumps water in until it is full and it shuts off again. I have tried resetting the machine and unplugging it and still have no luck. Any ideas where I should start looking? Control board, cycle sensors, impeller, etc.?

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

From the factory they come set for a flow meter fill, that sounds like the problem. Follow these steps and change it to a timed fill.

1. Turn off the main switch (I/0)

2. Wait for at least 5 seconds

3. Keep the Programme and Start buttons

depressed (S1 & S2)

4. Turn on the main switch (I/0)

5. Release the Programme and Start buttons

(S1 & S2) L7 flashes

The water intake can now be adjusted by pres-

sing S1 once again. L7 is flashing continuously

during the operation.

L1 extinguished: Volume-controlled water intake

(regulated via the flow sensor)

L1 lit: Time-controlled water intake

Confirm your choice by pressing Start (S2). The

programme returns to the main menu.

Share this post


Link to post
Share on other sites

Thank you for replying. I tried switching the cycle from the flow sensor to time-controlled per your instructions and it worked! Thank you so much for your help.

Share this post


Link to post
Share on other sites

Good job, thanks for letting us know the outcome.

Share this post


Link to post
Share on other sites