Jump to content
Click here to check out our structured, online appliance repair training courses for rookies and experienced techs.

FAQs | Repair Videos | Academy | Newsletter | Podcast | Contact

Stay connected with us...

Subscribe to our YouTube channel for lots of appliance repair tips and help! Subscribe to our MST Radio podcast to learn secrets of the trade. Sign up for our free newsletter and keep up with all things Appliantology.

RayHess

Kenmore Microwave 721.66339011 burn smell

Recommended Posts

RayHess

I have a Kenmore Microwave model: 721.66339011.  It has started to put out an "electrical burn" smell when running.   It appears to run fine still, heats, and works correctly.  I have the top off and can run it.  I can't see an smoke or isolate any particular part that seems to be the source of the smell.  How do I troubleshoot this?  Thanks for any help.

Ray

 

Share this post


Link to post
Share on other sites

Need appliance parts? Call 877-803-7957 now!

leamy

does it have a sweet order to the smell?

if do the high voltage transformer is failing

check the door switches for burnt/ heated push on connectors

they will also melt were the lugs go into the switch body

also the filter board with the main fuse on it can have

loose connections on the bottom of the board

this is an unit made by lg for sears

steve

Edited by leamy

Share this post


Link to post
Share on other sites
RayHess
On ‎1‎/‎23‎/‎2016 at 11:22 AM, RayHess said:

I have a Kenmore Microwave model: 721.66339011.  It has started to put out an "electrical burn" smell when running.   It appears to run fine still, heats, and works correctly.  I have the top off and can run it.  I can't see an smoke or isolate any particular part that seems to be the source of the smell.  How do I troubleshoot this?  Thanks for any help.

Ray

 

Thanks Leamy.

Not sure its a sweet odor, my son said yes, my wife said no, and I can't decide..  door switches are fine and all connections seems solid.  close sniffing while running it seems to be coming from the mag although that is right above the transformer and the fan is blowing over both.  Could not see any smoke and it works fine.  Anything I can check to voltage wise?  Thanks for your help.

Ray

 

 

Share this post


Link to post
Share on other sites
RayHess

Any suggestions that don't include paying $60 for a DVD set or $90 for a complete service repair book?  This microwave isn't worth that much. 

Thanks, Ray.

Share this post


Link to post
Share on other sites
tpoindexter
1 hour ago, RayHess said:

Any suggestions that don't include paying $60 for a DVD set or $90 for a complete service repair book?  This microwave isn't worth that much. 

Thanks, Ray.

If you'll go to the link I sent you above and go down the left side you'll find all the trouble shooting info you need. You don't have to pay a thing. Just do some reading and look at some pictures.

  • Like 1

Share this post


Link to post
Share on other sites
RayHess

Thanks, I missed those links.  I'll see what I can find out and get back to you. Ray

 

Share this post


Link to post
Share on other sites
RayHess

Well, it looks like the transformer.  After looking at the price and everything my wife decided she wanted a new one.  Thanks to all for your help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.